CVE catalog

CVE-2022-23318

pcf2bdf: CVE-2022-23318

[CVE catalog]

Severity
Low
Source
[NVD] · [CVE record]
EPSS
0.79% · Oct 25, 2026

A heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory access via a specially crafted PCF font file. This out-of-bound read may lead to an application crash, information disclosure via program memory or other context-dependent impact.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianpcf2bdfsid1.07-1fixed
Debianpcf2bdfforky1.07-1fixed
Debianpcf2bdftrixie1.07-1fixed
Debianpcf2bdfbookworm1.07-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianpcf2bdfsourcesid1.07-1unimportantNot reportedNot reported
Debianpcf2bdfsourceforky1.07-1unimportantNot reportedNot reported
Debianpcf2bdfsourcetrixie1.07-1unimportantNot reportedNot reported
Debianpcf2bdfsourcebookworm1.07-1unimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [pcf2bdf]Fixed
    Details (2)
    • 1.07-1 · amd64 · bookworm

      Fixed · Fixed: 1.07-1

      dsa · pcf2bdf · debian · bookworm

    • 1.07-1 · arm64 · bookworm

      Fixed · Fixed: 1.07-1

      dsa · pcf2bdf · debian · bookworm

Observed:

References