
CVE catalog
CVE-2022-23457
ESAPI vulnerabilities
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.85% · Oct 25, 2026
ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, the default implementation of `Validator.getValidDirectoryPath(String, String, File, boolean)` may incorrectly treat the tested input string as a child of the specified parent directory. This potentially could allow control-flow bypass checks to be defeated if an attack can specify the entire string representing the 'input' path. This vulnerability is patched in release 2.3.0.0 of ESAPI. As a workaround, it is possible to write one's own implementation of the Validator interface. However, maintainers do not recommend this.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | libowasp-esapi-java | sid | 2.4.0.0-3 | fixed |
| Debian | libowasp-esapi-java | trixie | 2.4.0.0-2.1 | fixed |
| Debian | libowasp-esapi-java | bookworm | 2.4.0.0-2 | fixed |
| Ubuntu | libowasp-esapi-java | noble | 2.4.0.0-2ubuntu0.1 | fixed |
| Ubuntu | libowasp-esapi-java | pro | 2.1.0-3.1 | vulnerable |
| Ubuntu | libowasp-esapi-java | pro | 2.2.3.1-1 | vulnerable |
| Ubuntu | libowasp-esapi-java | pro | 2.2.3.1-1ubuntu0.1~esm1 | fixed |
| Ubuntu | libowasp-esapi-java | 24.04 | 2.4.0.0-2 | vulnerable |
| Ubuntu | libowasp-esapi-java | 24.04 | 2.4.0.0-2ubuntu0.1 | fixed |
| Ubuntu | libowasp-esapi-java | pro | 2.1.0-3.1 | vulnerable |
| Ubuntu | libowasp-esapi-java | pro | 2.2.3.1-1 | vulnerable |
| Ubuntu | libowasp-esapi-java | pro | 2.2.3.1-1ubuntu0.1~esm1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | libowasp-esapi-java | source | sid | 2.4.0.0-1 | not yet assigned | Not reported | [1010339] |
| Debian | libowasp-esapi-java | source | trixie | 2.4.0.0-1 | not yet assigned | Not reported | [1010339] |
| Debian | libowasp-esapi-java | source | bookworm | 2.4.0.0-1 | not yet assigned | Not reported | [1010339] |
| Ubuntu | libowasp-esapi-java | deb | noble | 2.4.0.0-2ubuntu0.1 | Not reported | Not reported | Not reported |
| Ubuntu | libowasp-esapi-java | deb | pro | 2.2.3.1-1ubuntu0.1~esm1 | Not reported | USN-8181-1 | Not reported |
| Ubuntu | libowasp-esapi-java | deb | 24.04 | 2.4.0.0-2ubuntu0.1 | Not reported | USN-8181-1 | Not reported |
| Ubuntu | libowasp-esapi-java | deb | pro | 2.2.3.1-1ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2022-23457 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libowasp-esapi-java]Fixed
Details (2)
2.4.0.0-2· all · bookwormFixed · Fixed:
2.4.0.0-1usn · libowasp-esapi-java · debian · bookworm
2.4.0.0-2· all · bookwormFixed · Fixed:
2.4.0.0-1usn · libowasp-esapi-java · debian · bookworm
Observed:
References
- [https://osv.dev/vulnerability/DLA-4246-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-23457]
- [https://osv.dev/vulnerability/USN-8181-1]
- [https://security-tracker.debian.org/tracker/CVE-2022-23457]
- [https://ubuntu.com/security/notices/USN-8181-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-0131.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Ubuntu Security Notices (USN)]