
CVE catalog
CVE-2022-23514
ruby-loofah: CVE-2022-23514
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.83% · Oct 25, 2026
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah < 2.19.1 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ruby-loofah | sid | 2.25.2-1 | fixed |
| Debian | ruby-loofah | forky | 2.25.2-1 | fixed |
| Debian | ruby-loofah | trixie | 2.24.0-1 | fixed |
| Debian | ruby-loofah | bookworm | 2.19.1-1 | fixed |
| Suse | rubygem-loofah | linux enterprise high availability extension 15 sp1 | 2.2.2-150000.4.9.1 | fixed |
| Suse | rubygem-loofah | linux enterprise high availability extension 15 sp2 | 2.2.2-150000.4.9.1 | fixed |
| Suse | rubygem-loofah | linux enterprise high availability extension 15 sp3 | 2.2.2-150000.4.9.1 | fixed |
| Suse | rubygem-loofah | linux enterprise high availability extension 15 sp4 | 2.2.2-150000.4.9.1 | fixed |
| Opensuse | rubygem-loofah | leap 15.4 | 2.2.2-150000.4.9.1 | fixed |
| Opensuse | rubygem-loofah | tumbleweed | 2.19.1-1.1 | fixed |
| Ubuntu | ruby-loofah | 16.04 | 2.0.2-1 | vulnerable |
| Ubuntu | ruby-loofah | 16.04 | 2.0.3-1 | vulnerable |
| Ubuntu | ruby-loofah | 16.04 | 2.0.3-2 | vulnerable |
| Ubuntu | ruby-loofah | 16.04 | 2.0.3-2+deb9u1build0.16.04.1 | vulnerable |
| Ubuntu | ruby-loofah | 16.04 | 2.0.3-2+deb9u2build0.16.04.1 | vulnerable |
| Ubuntu | ruby-loofah | 16.04 | 2.0.3-2+deb9u3build0.16.04.1 | vulnerable |
| Ubuntu | ruby-loofah | 18.04 | 2.0.3-2 | vulnerable |
| Ubuntu | ruby-loofah | 18.04 | 2.2.2-1 | vulnerable |
| Ubuntu | ruby-loofah | 20.04 | 2.2.3-1 | vulnerable |
| Ubuntu | ruby-loofah | 20.04 | 2.3.1+dfsg-1 | vulnerable |
| Ubuntu | ruby-loofah | 20.04 | 2.4.0+dfsg-1 | vulnerable |
| Ubuntu | ruby-loofah | 22.04 | 2.12.0-1 | vulnerable |
| Ubuntu | ruby-loofah | 22.04 | 2.13.0-1 | vulnerable |
| Ubuntu | ruby-loofah | 22.04 | 2.13.0-2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ruby-loofah | source | sid | 2.19.1-1 | not yet assigned | Not reported | [1026083] |
| Debian | ruby-loofah | source | forky | 2.19.1-1 | not yet assigned | Not reported | [1026083] |
| Debian | ruby-loofah | source | trixie | 2.19.1-1 | not yet assigned | Not reported | [1026083] |
| Debian | ruby-loofah | source | bookworm | 2.19.1-1 | not yet assigned | Not reported | [1026083] |
| Suse | rubygem-loofah | rpm | linux enterprise high availability extension 15 sp1 | 2.2.2-150000.4.9.1 | Not reported | SUSE-SU-2023:1657-1 | Not reported |
| Suse | rubygem-loofah | rpm | linux enterprise high availability extension 15 sp2 | 2.2.2-150000.4.9.1 | Not reported | SUSE-SU-2023:1657-1 | Not reported |
| Suse | rubygem-loofah | rpm | linux enterprise high availability extension 15 sp3 | 2.2.2-150000.4.9.1 | Not reported | SUSE-SU-2023:1657-1 | Not reported |
| Suse | rubygem-loofah | rpm | linux enterprise high availability extension 15 sp4 | 2.2.2-150000.4.9.1 | Not reported | SUSE-SU-2023:1657-1 | Not reported |
| Opensuse | rubygem-loofah | rpm | leap 15.4 | 2.2.2-150000.4.9.1 | Not reported | SUSE-SU-2023:1657-1 | Not reported |
| Opensuse | rubygem-loofah | rpm | tumbleweed | 2.19.1-1.1 | Not reported | OPENSUSE-SU-2024:12768-1 | Not reported |
OpenFactory catalog packages
[openSUSE Tumbleweed]
- [ruby4.0-rubygem-loofah]Unknown
Source package: [rubygem-loofah]
Details (1)
2.25.0-1.3· x86_64 · tumbleweedUnknown · Fixed:
2.19.1-1.1Version impact unknown
dsa · rubygem-loofah · opensuse · tumbleweed
[Debian 12 (Bookworm)]
- [ruby-loofah]Fixed
Details (2)
2.19.1-1· all · bookwormFixed · Fixed:
2.19.1-1dsa · ruby-loofah · debian · bookworm
2.19.1-1· all · bookwormFixed · Fixed:
2.19.1-1dsa · ruby-loofah · debian · bookworm
Observed:
References
- [https://access.redhat.com/errata/RHSA-2023:2097]
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2023_1657-1.json]
- [https://osv.dev/vulnerability/DLA-3565-1]
- [https://osv.dev/vulnerability/DLA-3901-1]
- [https://osv.dev/vulnerability/SUSE-SU-2023:1657-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-23514]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:12768-1]
- [https://security-tracker.debian.org/tracker/CVE-2022-23514]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-1143.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]