
CVE catalog
CVE-2022-23516
ruby-loofah: CVE-2022-23516
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.17% · Oct 27, 2026
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1. Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | ruby-loofah | sid | 2.25.2-1 | fixed |
| Debian | ruby-loofah | forky | 2.25.2-1 | fixed |
| Debian | ruby-loofah | trixie | 2.24.0-1 | fixed |
| Debian | ruby-loofah | bookworm | 2.19.1-1 | fixed |
| Ubuntu | ruby-loofah | 16.04 | 2.0.2-1 | vulnerable |
| Ubuntu | ruby-loofah | 16.04 | 2.0.3-1 | vulnerable |
| Ubuntu | ruby-loofah | 16.04 | 2.0.3-2 | vulnerable |
| Ubuntu | ruby-loofah | 16.04 | 2.0.3-2+deb9u1build0.16.04.1 | vulnerable |
| Ubuntu | ruby-loofah | 16.04 | 2.0.3-2+deb9u2build0.16.04.1 | vulnerable |
| Ubuntu | ruby-loofah | 16.04 | 2.0.3-2+deb9u3build0.16.04.1 | vulnerable |
| Ubuntu | ruby-loofah | 18.04 | 2.0.3-2 | vulnerable |
| Ubuntu | ruby-loofah | 18.04 | 2.2.2-1 | vulnerable |
| Ubuntu | ruby-loofah | 20.04 | 2.2.3-1 | vulnerable |
| Ubuntu | ruby-loofah | 20.04 | 2.3.1+dfsg-1 | vulnerable |
| Ubuntu | ruby-loofah | 20.04 | 2.4.0+dfsg-1 | vulnerable |
| Ubuntu | ruby-loofah | 22.04 | 2.12.0-1 | vulnerable |
| Ubuntu | ruby-loofah | 22.04 | 2.13.0-1 | vulnerable |
| Ubuntu | ruby-loofah | 22.04 | 2.13.0-2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | ruby-loofah | source | sid | 2.19.1-1 | not yet assigned | Not reported | [1026083] |
| Debian | ruby-loofah | source | forky | 2.19.1-1 | not yet assigned | Not reported | [1026083] |
| Debian | ruby-loofah | source | trixie | 2.19.1-1 | not yet assigned | Not reported | [1026083] |
| Debian | ruby-loofah | source | bookworm | 2.19.1-1 | not yet assigned | Not reported | [1026083] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [ruby-loofah]Fixed
Details (2)
2.19.1-1· all · bookwormFixed · Fixed:
2.19.1-1dsa · ruby-loofah · debian · bookworm
2.19.1-1· all · bookwormFixed · Fixed:
2.19.1-1dsa · ruby-loofah · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_10353-1.json]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-23516]
- [https://security-tracker.debian.org/tracker/CVE-2022-23516]
- [https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-23516.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-1143.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]