
CVE catalog
CVE-2022-23527
libapache2-mod-auth-openidc: CVE-2022-23527
- Severity
- Medium · CVSS 6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.94% · Oct 25, 2026
mod_auth_openidc is an OpenID Certified™ authentication and authorization module for the Apache 2.x HTTP server. Versions prior to 2.4.12.2 are vulnerable to Open Redirect. When providing a logout parameter to the redirect URI, the existing code in oidc_validate_redirect_url() does not properly check for URLs that start with /\t, leading to an open redirect. This issue has been patched in version 2.4.12.2. Users unable to upgrade can mitigate the issue by configuring mod_auth_openidc to only allow redirection when the destination matches a given regular expression with OIDCRedirectURLsAllowed.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | libapache2-mod-auth-openidc | sid | 2.4.20.3-1 | fixed |
| Debian | libapache2-mod-auth-openidc | forky | 2.4.20.3-1 | fixed |
| Debian | libapache2-mod-auth-openidc | trixie | 2.4.17-1 | fixed |
| Debian | libapache2-mod-auth-openidc | trixie-security | 2.4.17-1+deb13u1 | fixed |
| Debian | libapache2-mod-auth-openidc | bookworm | 2.4.12.3-2+deb12u4 | fixed |
| Debian | libapache2-mod-auth-openidc | bookworm-security | 2.4.12.3-2+deb12u5 | fixed |
| Opensuse | apache2-mod_auth_openidc | tumbleweed | 2.4.12.2-1.1 | fixed |
| Suse | apache2-mod_auth_openidc | openstack cloud 9 | 2.4.0-7.9.1 | fixed |
| Suse | apache2-mod_auth_openidc | openstack cloud crowbar 9 | 2.4.0-7.9.1 | fixed |
| Suse | apache2-mod_auth_openidc | linux enterprise server for sap applications 12 sp4 | 2.4.0-7.9.1 | fixed |
| Suse | apache2-mod_auth_openidc | linux enterprise server 12 sp4-espos | 2.4.0-7.9.1 | fixed |
| Suse | apache2-mod_auth_openidc | linux enterprise server 12 sp4-ltss | 2.4.0-7.9.1 | fixed |
| Suse | apache2-mod_auth_openidc | linux enterprise server 12 sp5 | 2.4.0-7.9.1 | fixed |
| Suse | apache2-mod_auth_openidc | linux enterprise server for sap applications 12 sp5 | 2.4.0-7.9.1 | fixed |
| Ubuntu | libapache2-mod-auth-openidc | 18.04 | 2.1.6-1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 18.04 | 2.3.1-2 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 18.04 | 2.3.2-1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 18.04 | 2.3.2-1build1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 18.04 | 2.3.3-1build1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 20.04 | 2.3.10.2-1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 20.04 | 2.4.0.4-1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 20.04 | 2.4.1-1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 22.04 | 2.4.9-1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 22.04 | 2.4.9.4-1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 22.04 | 2.4.10-1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 22.04 | 2.4.10-1build1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 22.04 | 2.4.11-1 | vulnerable |
| Ubuntu | libapache2-mod-auth-openidc | 22.04 | 2.4.11-1ubuntu0.1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | libapache2-mod-auth-openidc | source | sid | 2.4.12.2-1 | not yet assigned | Not reported | [1026444] |
| Debian | libapache2-mod-auth-openidc | source | forky | 2.4.12.2-1 | not yet assigned | Not reported | [1026444] |
| Debian | libapache2-mod-auth-openidc | source | trixie | 2.4.12.2-1 | not yet assigned | Not reported | [1026444] |
| Debian | libapache2-mod-auth-openidc | source | bookworm | 2.4.12.2-1 | not yet assigned | Not reported | [1026444] |
| Opensuse | apache2-mod_auth_openidc | rpm | tumbleweed | 2.4.12.2-1.1 | Not reported | OPENSUSE-SU-2024:12584-1 | Not reported |
| Suse | apache2-mod_auth_openidc | rpm | openstack cloud 9 | 2.4.0-7.9.1 | Not reported | SUSE-SU-2023:1837-1 | Not reported |
| Suse | apache2-mod_auth_openidc | rpm | openstack cloud crowbar 9 | 2.4.0-7.9.1 | Not reported | SUSE-SU-2023:1837-1 | Not reported |
| Suse | apache2-mod_auth_openidc | rpm | linux enterprise server for sap applications 12 sp4 | 2.4.0-7.9.1 | Not reported | SUSE-SU-2023:1837-1 | Not reported |
| Suse | apache2-mod_auth_openidc | rpm | linux enterprise server 12 sp4-espos | 2.4.0-7.9.1 | Not reported | SUSE-SU-2023:1837-1 | Not reported |
| Suse | apache2-mod_auth_openidc | rpm | linux enterprise server 12 sp4-ltss | 2.4.0-7.9.1 | Not reported | SUSE-SU-2023:1837-1 | Not reported |
| Suse | apache2-mod_auth_openidc | rpm | linux enterprise server 12 sp5 | 2.4.0-7.9.1 | Not reported | SUSE-SU-2023:1837-1 | Not reported |
| Suse | apache2-mod_auth_openidc | rpm | linux enterprise server for sap applications 12 sp5 | 2.4.0-7.9.1 | Not reported | SUSE-SU-2023:1837-1 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [libapache2-mod-auth-openidc]Unknown
Details (4)
2.4.12.3-2+deb12u4· amd64 · bookwormFixed · Fixed:
2.4.12.2-1dsa · libapache2-mod-auth-openidc · debian · bookworm
2.4.12.3-2+deb12u4· arm64 · bookwormFixed · Fixed:
2.4.12.2-1dsa · libapache2-mod-auth-openidc · debian · bookworm
2.4.12.3-2+deb12u4· amd64 · bookworm-securityFixed · Fixed:
2.4.12.2-1dsa · libapache2-mod-auth-openidc · debian · bookworm
2.4.12.3-2+deb12u4· arm64 · bookworm-securityFixed · Fixed:
2.4.12.2-1dsa · libapache2-mod-auth-openidc · debian · bookworm
[openSUSE Tumbleweed]
- [apache2-mod_auth_openidc]Unknown
Source package: [apache2-mod_auth_openidc]
Details (1)
2.4.20.2-1.1· x86_64 · tumbleweedFixed · Fixed:
2.4.12.2-1.1dsa · apache2-mod_auth_openidc · opensuse · tumbleweed
Observed:
References
- [https://access.redhat.com/errata/RHSA-2023:6365]
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2023_6940.json]
- [https://osv.dev/vulnerability/SUSE-SU-2023:1837-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-23527]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:12584-1]
- [https://security-tracker.debian.org/tracker/CVE-2022-23527]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-2853.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]