
CVE catalog
CVE-2022-23613
xrdp: CVE-2022-23613
- Severity
- High · CVSS 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.49% · Oct 25, 2026
xrdp is an open source remote desktop protocol (RDP) server. In affected versions an integer underflow leading to a heap overflow in the sesman server allows any unauthenticated attacker which is able to locally access a sesman server to execute code as root. This vulnerability has been patched in version 0.9.18.1 and above. Users are advised to upgrade. There are no known workarounds.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | xrdp | sid | 0.10.6.1-3 | fixed |
| Debian | xrdp | forky | 0.10.6.1-3 | fixed |
| Debian | xrdp | trixie | 0.10.1-3.1+deb13u2 | fixed |
| Debian | xrdp | trixie-security | 0.10.1-3.1+deb13u2 | fixed |
| Debian | xrdp | bookworm | 0.9.21.1-1+deb12u2 | fixed |
| Debian | xrdp | bookworm-security | 0.9.21.1-1+deb12u3 | fixed |
| Opensuse | xrdp | tumbleweed | 0.9.19-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | xrdp | source | sid | 0.9.17-2.1 | not yet assigned | Not reported | [1005304] |
| Debian | xrdp | source | forky | 0.9.17-2.1 | not yet assigned | Not reported | [1005304] |
| Debian | xrdp | source | trixie | 0.9.17-2.1 | not yet assigned | Not reported | [1005304] |
| Debian | xrdp | source | bookworm | 0.9.17-2.1 | not yet assigned | Not reported | [1005304] |
| Opensuse | xrdp | rpm | tumbleweed | 0.9.19-1.1 | Not reported | OPENSUSE-SU-2024:12112-1 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [xrdp]Unknown
Details (6)
0.9.21.1-1+deb12u2· amd64 · bookwormFixed · Fixed:
0.9.17-2.1dsa · xrdp · debian · bookworm
0.9.21.1-1+deb12u2· arm64 · bookwormFixed · Fixed:
0.9.17-2.1dsa · xrdp · debian · bookworm
0.9.24-5~bpo12+1· amd64 · bookworm-backportsFixed · Fixed:
0.9.17-2.1dsa · xrdp · debian · bookworm
0.9.24-5~bpo12+1· arm64 · bookworm-backportsFixed · Fixed:
0.9.17-2.1dsa · xrdp · debian · bookworm
0.9.21.1-1+deb12u3· amd64 · bookworm-securityFixed · Fixed:
0.9.17-2.1dsa · xrdp · debian · bookworm
0.9.21.1-1+deb12u3· arm64 · bookworm-securityFixed · Fixed:
0.9.17-2.1dsa · xrdp · debian · bookworm
[openSUSE Tumbleweed]
- [xrdp]Unknown
Source package: [xrdp]
Details (1)
0.10.6.1-1.1· x86_64 · tumbleweedFixed · Fixed:
0.9.19-1.1dsa · xrdp · opensuse · tumbleweed
- [xrdp-devel]Unknown
Source package: [xrdp]
Details (1)
0.10.6.1-1.1· x86_64 · tumbleweedUnknown · Fixed:
0.9.19-1.1Version impact unknown
dsa · xrdp · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_12112-1.json]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:12112-1]
- [https://security-tracker.debian.org/tracker/CVE-2022-23613]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [SUSE security advisories and VEX]