
CVE catalog
CVE-2022-23647
node-prismjs: CVE-2022-23647
- Severity
- Medium · CVSS 6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.43% · Oct 25, 2026
Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | node-prismjs | sid | 1.30.0+dfsg+~1.26.6-1 | fixed |
| Debian | node-prismjs | forky | 1.30.0+dfsg+~1.26.6-1 | fixed |
| Debian | node-prismjs | trixie | 1.29.0+dfsg+~1.26.0-1 | fixed |
| Debian | node-prismjs | bookworm | 1.29.0+dfsg+~1.26.0-1 | fixed |
| Ubuntu | node-prismjs | 20.04 | 1.11.0+dfsg-2 | vulnerable |
| Ubuntu | node-prismjs | 20.04 | 1.11.0+dfsg-3 | vulnerable |
| Ubuntu | node-prismjs | 22.04 | 1.23.0+dfsg-1 | vulnerable |
| Ubuntu | node-prismjs | 22.04 | 1.25.0+dfsg-1 | vulnerable |
| Ubuntu | node-prismjs | 22.04 | 1.27.0+dfsg+~1.26.0-1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | node-prismjs | source | sid | 1.27.0+dfsg+~1.26.0-1 | not yet assigned | Not reported | Not reported |
| Debian | node-prismjs | source | forky | 1.27.0+dfsg+~1.26.0-1 | not yet assigned | Not reported | Not reported |
| Debian | node-prismjs | source | trixie | 1.27.0+dfsg+~1.26.0-1 | not yet assigned | Not reported | Not reported |
| Debian | node-prismjs | source | bookworm | 1.27.0+dfsg+~1.26.0-1 | not yet assigned | Not reported | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [node-prismjs]Fixed
Details (2)
1.29.0+dfsg+~1.26.0-1· all · bookwormFixed · Fixed:
1.27.0+dfsg+~1.26.0-1dsa · node-prismjs · debian · bookworm
1.29.0+dfsg+~1.26.0-1· all · bookwormFixed · Fixed:
1.27.0+dfsg+~1.26.0-1dsa · node-prismjs · debian · bookworm
Observed:
References
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-23647]
- [https://security-tracker.debian.org/tracker/CVE-2022-23647]
- [https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-23647.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-0554.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]