CVE catalog

CVE-2022-23808

phpmyadmin: CVE-2022-23808

[CVE catalog]

Severity
Medium · CVSS 6.1CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Published
Source
[NVD] · [CVE record]
EPSS
7.94% · Oct 25, 2026

An issue was discovered in phpMyAdmin 5.1 before 5.1.2. An attacker can inject malicious code into aspects of the setup script, which can allow XSS or HTML injection.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianphpmyadminsid4:5.2.4~dev~git20260809.e0909b211b+dfsg-1fixed
Debianphpmyadminforky4:5.2.4~dev~git20260809.e0909b211b+dfsg-1fixed
Debianphpmyadmintrixie4:5.2.2-really+dfsg-1+deb13u1fixed
Debianphpmyadminbookworm4:5.2.1+dfsg-1+deb12u1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianphpmyadminsourcesid4:5.1.3+dfsg1-1unimportantNot reportedNot reported
Debianphpmyadminsourceforky4:5.1.3+dfsg1-1unimportantNot reportedNot reported
Debianphpmyadminsourcetrixie4:5.1.3+dfsg1-1unimportantNot reportedNot reported
Debianphpmyadminsourcebookworm4:5.1.3+dfsg1-1unimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [phpmyadmin]Fixed
    Details (2)
    • 4:5.2.1+dfsg-1+deb12u1 · all · bookworm

      Fixed · Fixed: 4:5.1.3+dfsg1-1

      dsa · phpmyadmin · debian · bookworm

    • 4:5.2.1+dfsg-1+deb12u1 · all · bookworm

      Fixed · Fixed: 4:5.1.3+dfsg1-1

      dsa · phpmyadmin · debian · bookworm

Observed:

References