
CVE catalog
CVE-2022-24675
Security update for go1.18
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 9.95% · Oct 25, 2026
encoding/pem in Go before 1.17.9 and 1.18.x before 1.18.1 has a Decode stack overflow via a large amount of PEM data.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | golang-1.18 | 18.04 | 1.18.1-1ubuntu1~18.04.3 | fixed |
| Ubuntu | golang-1.18 | 20.04 | 1.18.1-1ubuntu1~20.04.1 | fixed |
| Ubuntu | golang-1.17 | 22.04 | 1.17-1ubuntu2 | vulnerable |
| Ubuntu | golang-1.17 | 22.04 | 1.17.3-1ubuntu1 | vulnerable |
| Ubuntu | golang-1.17 | 22.04 | 1.17.3-1ubuntu2 | vulnerable |
| Ubuntu | golang-1.17 | 22.04 | 1.17.13-3ubuntu1 | vulnerable |
| Ubuntu | golang-1.17 | 22.04 | 1.17.13-3ubuntu1.2 | vulnerable |
| Ubuntu | golang-1.17 | 22.04 | 1.17.13-3ubuntu1.3 | vulnerable |
| Ubuntu | golang-1.18 | 22.04 | 1.18~beta1-0ubuntu1 | vulnerable |
| Ubuntu | golang-1.18 | 22.04 | 1.18~beta2-1ubuntu1 | vulnerable |
| Ubuntu | golang-1.18 | 22.04 | 1.18~beta2-1ubuntu2 | vulnerable |
| Ubuntu | golang-1.18 | 22.04 | 1.18~rc1-1ubuntu1 | vulnerable |
| Ubuntu | golang-1.18 | 22.04 | 1.18-1ubuntu1 | vulnerable |
| Ubuntu | golang-1.18 | 22.04 | 1.18.1-1ubuntu1 | fixed |
| Opensuse | go1.18 | tumbleweed | 1.18.1-1.1 | fixed |
| Suse | go1.17 | linux enterprise module for development tools 15 sp3 | 1.17.9-150000.1.28.1 | fixed |
| Suse | go1.17 | linux enterprise real time 15 sp2 | 1.17.9-150000.1.28.1 | fixed |
| Opensuse | go1.17 | leap 15.3 | 1.17.9-150000.1.28.1 | fixed |
| Opensuse | go1.17 | leap 15.4 | 1.17.9-150000.1.28.1 | fixed |
| Opensuse | go1.17 | tumbleweed | 1.17.9-1.1 | fixed |
| Suse | go1.18 | linux enterprise module for development tools 15 sp3 | 1.18.1-150000.1.11.1 | fixed |
| Opensuse | go1.18 | leap 15.3 | 1.18.1-150000.1.11.1 | fixed |
| Opensuse | go1.18 | leap 15.4 | 1.18.1-150000.1.11.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Ubuntu | golang-1.18 | deb | 18.04 | 1.18.1-1ubuntu1~18.04.3 | Not reported | UBUNTU-CVE-2022-24675 | Not reported |
| Ubuntu | golang-1.18 | deb | 20.04 | 1.18.1-1ubuntu1~20.04.1 | Not reported | UBUNTU-CVE-2022-24675 | Not reported |
| Ubuntu | golang-1.18 | deb | 22.04 | 1.18.1-1ubuntu1 | Not reported | UBUNTU-CVE-2022-24675 | Not reported |
| Opensuse | go1.18 | rpm | tumbleweed | 1.18.1-1.1 | Not reported | OPENSUSE-SU-2024:11991-1 | Not reported |
| Suse | go1.17 | rpm | linux enterprise module for development tools 15 sp3 | 1.17.9-150000.1.28.1 | Not reported | SUSE-SU-2022:1411-1 | Not reported |
| Suse | go1.17 | rpm | linux enterprise real time 15 sp2 | 1.17.9-150000.1.28.1 | Not reported | SUSE-SU-2022:1411-1 | Not reported |
| Opensuse | go1.17 | rpm | leap 15.3 | 1.17.9-150000.1.28.1 | Not reported | SUSE-SU-2022:1411-1 | Not reported |
| Opensuse | go1.17 | rpm | leap 15.4 | 1.17.9-150000.1.28.1 | Not reported | SUSE-SU-2022:1411-1 | Not reported |
| Opensuse | go1.17 | rpm | tumbleweed | 1.17.9-1.1 | Not reported | OPENSUSE-SU-2024:12004-1 | Not reported |
| Suse | go1.18 | rpm | linux enterprise module for development tools 15 sp3 | 1.18.1-150000.1.11.1 | Not reported | SUSE-SU-2022:1410-1 | Not reported |
| Opensuse | go1.18 | rpm | leap 15.3 | 1.18.1-150000.1.11.1 | Not reported | SUSE-SU-2022:1410-1 | Not reported |
| Opensuse | go1.18 | rpm | leap 15.4 | 1.18.1-150000.1.11.1 | Not reported | SUSE-SU-2022:1410-1 | Not reported |
OpenFactory catalog packages
No matching packages in this catalog.
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2022_5337.json]
- [https://osv.dev/vulnerability/SUSE-SU-2022:1410-1]
- [https://osv.dev/vulnerability/SUSE-SU-2022:1411-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-24675]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:11991-1]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:12004-1]
- [https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-24675.json]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]