
CVE catalog
CVE-2022-24775
php-guzzlehttp-psr7: CVE-2022-24775
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.48% · Oct 25, 2026
guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | php-guzzlehttp-psr7 | sid | 2.13.1-1 | fixed |
| Debian | php-guzzlehttp-psr7 | forky | 2.13.1-1 | fixed |
| Debian | php-guzzlehttp-psr7 | trixie | 2.7.1-1+deb13u2 | fixed |
| Debian | php-guzzlehttp-psr7 | bookworm | 2.4.5-1+deb12u1 | fixed |
| Ubuntu | php-guzzlehttp-psr7 | 20.04 | 1.4.2-0.1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 20.04 | 1.4.2-0.1+deb10u2build0.20.04.1 | fixed |
| Ubuntu | php-guzzlehttp-psr7 | pro | 1.7.0-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | pro | 1.8.3-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | pro | 1.8.3-1ubuntu0.1~esm1 | fixed |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.1.0-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.2.0-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.2.1-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.2.2-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.2.2-1build1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 16.04 | 1.2.2-1ubuntu1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 20.04 | 1.4.2-0.1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | 20.04 | 1.4.2-0.1+deb10u2build0.20.04.1 | fixed |
| Ubuntu | php-guzzlehttp-psr7 | pro | 1.7.0-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | pro | 1.8.3-1 | vulnerable |
| Ubuntu | php-guzzlehttp-psr7 | pro | 1.8.3-1ubuntu0.1~esm1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | php-guzzlehttp-psr7 | source | sid | 1.8.5-1 | not yet assigned | Not reported | [1008236] |
| Debian | php-guzzlehttp-psr7 | source | forky | 1.8.5-1 | not yet assigned | Not reported | [1008236] |
| Debian | php-guzzlehttp-psr7 | source | trixie | 1.8.5-1 | not yet assigned | Not reported | [1008236] |
| Debian | php-guzzlehttp-psr7 | source | bookworm | 1.8.5-1 | not yet assigned | Not reported | [1008236] |
| Ubuntu | php-guzzlehttp-psr7 | deb | 20.04 | 1.4.2-0.1+deb10u2build0.20.04.1 | Not reported | USN-6670-1 | Not reported |
| Ubuntu | php-guzzlehttp-psr7 | deb | pro | 1.8.3-1ubuntu0.1~esm1 | Not reported | USN-6670-1 | Not reported |
| Ubuntu | php-guzzlehttp-psr7 | deb | 20.04 | 1.4.2-0.1+deb10u2build0.20.04.1 | Not reported | UBUNTU-CVE-2022-24775 | Not reported |
| Ubuntu | php-guzzlehttp-psr7 | deb | pro | 1.8.3-1ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2022-24775 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [php-guzzlehttp-psr7]Fixed
Details (2)
2.4.5-1+deb12u1· all · bookwormFixed · Fixed:
1.8.5-1dsa · php-guzzlehttp-psr7 · debian · bookworm
2.4.5-1+deb12u1· all · bookwormFixed · Fixed:
1.8.5-1dsa · php-guzzlehttp-psr7 · debian · bookworm
Observed:
References
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-24775]
- [https://osv.dev/vulnerability/USN-6670-1]
- [https://security-tracker.debian.org/tracker/CVE-2022-24775]
- [https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-24775.json]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX]