
CVE catalog
CVE-2022-24891
ESAPI vulnerabilities
- Severity
- Medium
- Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.71% · Oct 25, 2026
ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, there is a potential for a cross-site scripting vulnerability in ESAPI caused by a incorrect regular expression for "onsiteURL" in the **antisamy-esapi.xml** configuration file that can cause "javascript:" URLs to fail to be correctly sanitized. This issue is patched in ESAPI 2.3.0.0. As a workaround, manually edit the **antisamy-esapi.xml** configuration files to change the "onsiteURL" regular expression. More information about remediation of the vulnerability, including the workaround, is available in the maintainers' release notes and security bulletin.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | libowasp-esapi-java | sid | 2.4.0.0-3 | fixed |
| Debian | libowasp-esapi-java | trixie | 2.4.0.0-2.1 | fixed |
| Debian | libowasp-esapi-java | bookworm | 2.4.0.0-2 | fixed |
| Ubuntu | libowasp-esapi-java | noble | 2.4.0.0-2ubuntu0.1 | fixed |
| Ubuntu | libowasp-esapi-java | pro | 2.1.0-3.1 | vulnerable |
| Ubuntu | libowasp-esapi-java | pro | 2.2.3.1-1 | vulnerable |
| Ubuntu | libowasp-esapi-java | pro | 2.2.3.1-1ubuntu0.1~esm1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | libowasp-esapi-java | source | sid | 2.4.0.0-1 | not yet assigned | Not reported | [1010339] |
| Debian | libowasp-esapi-java | source | trixie | 2.4.0.0-1 | not yet assigned | Not reported | [1010339] |
| Debian | libowasp-esapi-java | source | bookworm | 2.4.0.0-1 | not yet assigned | Not reported | [1010339] |
| Ubuntu | libowasp-esapi-java | deb | noble | 2.4.0.0-2ubuntu0.1 | Not reported | Not reported | Not reported |
| Ubuntu | libowasp-esapi-java | deb | pro | 2.2.3.1-1ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2022-24891 | Not reported |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libowasp-esapi-java]Fixed
Details (2)
2.4.0.0-2· all · bookwormFixed · Fixed:
2.4.0.0-1usn · libowasp-esapi-java · debian · bookworm
2.4.0.0-2· all · bookwormFixed · Fixed:
2.4.0.0-1usn · libowasp-esapi-java · debian · bookworm
Observed:
References
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-24891]
- [https://security-tracker.debian.org/tracker/CVE-2022-24891]
- [https://ubuntu.com/security/notices/USN-8181-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-0217.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Ubuntu Security Notices (USN)]