
CVE catalog
CVE-2022-25327
fscrypt: CVE-2022-25327
- Severity
- Medium · CVSS 5.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.11% · Oct 25, 2026
The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | fscrypt | sid | 0.3.7-1 | fixed |
| Debian | fscrypt | forky | 0.3.7-1 | fixed |
| Debian | fscrypt | trixie | 0.3.5-1 | fixed |
| Debian | fscrypt | bookworm | 0.3.3-1 | fixed |
| Ubuntu | fscrypt | 18.04 | 0.2.2-0ubuntu2 | vulnerable |
| Ubuntu | fscrypt | 18.04 | 0.2.2-0ubuntu2.1 | vulnerable |
| Ubuntu | fscrypt | 20.04 | 0.2.4-2 | vulnerable |
| Ubuntu | fscrypt | 20.04 | 0.2.5-1 | vulnerable |
| Ubuntu | fscrypt | 20.04 | 0.2.5-2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | fscrypt | source | sid | 0.3.3-1 | not yet assigned | Not reported | [1006485] |
| Debian | fscrypt | source | forky | 0.3.3-1 | not yet assigned | Not reported | [1006485] |
| Debian | fscrypt | source | trixie | 0.3.3-1 | not yet assigned | Not reported | [1006485] |
| Debian | fscrypt | source | bookworm | 0.3.3-1 | not yet assigned | Not reported | [1006485] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [fscrypt]Fixed
Source package: [fscrypt]
Details (2)
0.3.3-1+b6· amd64 · bookwormFixed · Fixed:
0.3.3-1dsa · fscrypt · debian · bookworm
0.3.3-1+b6· arm64 · bookwormFixed · Fixed:
0.3.3-1dsa · fscrypt · debian · bookworm
- [libpam-fscrypt]Fixed
Source package: [fscrypt]
Details (2)
0.3.3-1+b6· amd64 · bookwormFixed · Fixed:
0.3.3-1dsa · fscrypt · debian · bookworm
0.3.3-1+b6· arm64 · bookwormFixed · Fixed:
0.3.3-1dsa · fscrypt · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_11902-1.json]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-25327]
- [https://security-tracker.debian.org/tracker/CVE-2022-25327]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [SUSE security advisories and VEX]