
CVE catalog
CVE-2022-25328
fscrypt: CVE-2022-25328
- Severity
- High · CVSS 7.3
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.20% · Oct 25, 2026
The bash_completion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to version 0.3.3 or above
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | fscrypt | sid | 0.3.7-1 | fixed |
| Debian | fscrypt | forky | 0.3.7-1 | fixed |
| Debian | fscrypt | trixie | 0.3.5-1 | fixed |
| Debian | fscrypt | bookworm | 0.3.3-1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | fscrypt | source | sid | 0.3.3-1 | not yet assigned | Not reported | [1006485] |
| Debian | fscrypt | source | forky | 0.3.3-1 | not yet assigned | Not reported | [1006485] |
| Debian | fscrypt | source | trixie | 0.3.3-1 | not yet assigned | Not reported | [1006485] |
| Debian | fscrypt | source | bookworm | 0.3.3-1 | not yet assigned | Not reported | [1006485] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [fscrypt]Fixed
Source package: [fscrypt]
Details (2)
0.3.3-1+b6· amd64 · bookwormFixed · Fixed:
0.3.3-1dsa · fscrypt · debian · bookworm
0.3.3-1+b6· arm64 · bookwormFixed · Fixed:
0.3.3-1dsa · fscrypt · debian · bookworm
- [libpam-fscrypt]Fixed
Source package: [fscrypt]
Details (2)
0.3.3-1+b6· amd64 · bookwormFixed · Fixed:
0.3.3-1dsa · fscrypt · debian · bookworm
0.3.3-1+b6· arm64 · bookwormFixed · Fixed:
0.3.3-1dsa · fscrypt · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_11902-1.json]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-25328]
- [https://security-tracker.debian.org/tracker/CVE-2022-25328]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [SUSE security advisories and VEX]