CVE catalog

CVE-2022-25638

wolfssl affected and fixed versions

[CVE catalog]

In wolfSSL before 5.2.0, certificate validation may be bypassed during attempted authentication by a TLS 1.3 client to a TLS 1.3 server. This occurs when the sig_algo field differs between the certificate_verify message and the certificate message.

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
0.63% · Oct 27, 2026

Projects and upstream resources

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Distribution / releasePackageVersionStatusSource
Debiantrixiewolfssl5.2.0-1FixedDistribution-reported fixed boundary[CVE-2022-25638]
Debiantrixiewolfssl5.7.2-0.1+deb13u2Fixed[CVE-2022-25638]
Debiansidwolfssl5.2.0-1FixedDistribution-reported fixed boundary[CVE-2022-25638]
Debiansidwolfssl5.9.2-1.2Fixed[CVE-2022-25638]
Debianbookworm-securitywolfssl5.5.4-2+deb12u3Fixed[CVE-2022-25638]
Debianbookwormwolfssl5.2.0-1FixedDistribution-reported fixed boundary[CVE-2022-25638]
Debianbookwormwolfssl5.5.4-2+deb12u2Fixed[CVE-2022-25638]

Showing 7 fix observations. All 22 observations, including unknown and conflicting reports, are available below.

Provider details and historical evidence
Distribution / releasePackageVersionStatusSource
Debianbookwormwolfssl5.2.0-1FixedDistribution-reported fixed boundary[CVE-2022-25638]
Debianbookwormwolfssl5.5.4-2+deb12u2Fixed[CVE-2022-25638]
Debianbookworm-securitywolfssl5.5.4-2+deb12u3Fixed[CVE-2022-25638]
Debiansidwolfssl5.2.0-1FixedDistribution-reported fixed boundary[CVE-2022-25638]
Debiansidwolfssl5.9.2-1.2Fixed[CVE-2022-25638]
Debiantrixiewolfssl5.2.0-1FixedDistribution-reported fixed boundary[CVE-2022-25638]
Debiantrixiewolfssl5.7.2-0.1+deb13u2Fixed[CVE-2022-25638]
Ubuntu16.04wolfssl3.4.8+dfsg-1Affected[UBUNTU-CVE-2022-25638]
Ubuntu18.04wolfssl3.10.2+dfsg-2Affected[UBUNTU-CVE-2022-25638]
Ubuntu18.04wolfssl3.12.0+dfsg-1Affected[UBUNTU-CVE-2022-25638]
Ubuntu18.04wolfssl3.12.2+dfsg-1Affected[UBUNTU-CVE-2022-25638]
Ubuntu18.04wolfssl3.13.0+dfsg-1Affected[UBUNTU-CVE-2022-25638]
Ubuntu20.04wolfssl4.1.0+dfsg-2Affected[UBUNTU-CVE-2022-25638]
Ubuntu20.04wolfssl4.2.0+dfsg-1Affected[UBUNTU-CVE-2022-25638]
Ubuntu20.04wolfssl4.2.0+dfsg-2Affected[UBUNTU-CVE-2022-25638]
Ubuntu20.04wolfssl4.2.0+dfsg-3Affected[UBUNTU-CVE-2022-25638]
Ubuntu20.04wolfssl4.3.0+dfsg-2Affected[UBUNTU-CVE-2022-25638]
Ubuntu22.04wolfssl4.6.0-3Affected[UBUNTU-CVE-2022-25638]
Ubuntu22.04wolfssl5.0.0-1Affected[UBUNTU-CVE-2022-25638]
Ubuntu22.04wolfssl5.1.1-1Affected[UBUNTU-CVE-2022-25638]
Ubuntu22.04wolfssl5.2.0-1Affected[UBUNTU-CVE-2022-25638]
Ubuntu22.04wolfssl5.2.0-2Affected[UBUNTU-CVE-2022-25638]
Original provider fields
{
  "package_releases": [
    {
      "name": "wolfssl",
      "status": "fixed",
      "release": "sid",
      "version": "5.9.2-1.2"
    },
    {
      "name": "wolfssl",
      "status": "fixed",
      "release": "trixie",
      "version": "5.7.2-0.1+deb13u2"
    },
    {
      "name": "wolfssl",
      "status": "fixed",
      "release": "bookworm",
      "version": "5.5.4-2+deb12u2"
    },
    {
      "name": "wolfssl",
      "status": "fixed",
      "release": "bookworm-security",
      "version": "5.5.4-2+deb12u3"
    }
  ],
  "fixed_versions": [
    {
      "bug": null,
      "name": "wolfssl",
      "type": "source",
      "origin": null,
      "release": "sid",
      "urgency": "not yet assigned",
      "fixed_version": "5.2.0-1"
    },
    {
      "bug": null,
      "name": "wolfssl",
      "type": "source",
      "origin": null,
      "release": "trixie",
      "urgency": "not yet assigned",
      "fixed_version": "5.2.0-1"
    },
    {
      "bug": null,
      "name": "wolfssl",
      "type": "source",
      "origin": null,
      "release": "bookworm",
      "urgency": "not yet assigned",
      "fixed_version": "5.2.0-1"
    }
  ],
  "distribution_packages": [
    {
      "name": "wolfssl",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            }
          ]
        }
      ],
      "release": "16.04",
      "versions": [
        "3.4.8+dfsg-1"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-25638",
      "fixed_version": "",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2022-25638",
      "provider_updated_at": "2026-04-22T13:19:06.169884Z"
    },
    {
      "name": "wolfssl",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            }
          ]
        }
      ],
      "release": "18.04",
      "versions": [
        "3.10.2+dfsg-2",
        "3.12.0+dfsg-1",
        "3.12.2+dfsg-1",
        "3.13.0+dfsg-1"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-25638",
      "fixed_version": "",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2022-25638",
      "provider_updated_at": "2026-04-22T13:19:06.169884Z"
    },
    {
      "name": "wolfssl",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            }
          ]
        }
      ],
      "release": "20.04",
      "versions": [
        "4.1.0+dfsg-2",
        "4.2.0+dfsg-1",
        "4.2.0+dfsg-2",
        "4.2.0+dfsg-3",
        "4.3.0+dfsg-2"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-25638",
      "fixed_version": "",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2022-25638",
      "provider_updated_at": "2026-04-22T13:19:06.169884Z"
    },
    {
      "name": "wolfssl",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            }
          ]
        }
      ],
      "release": "22.04",
      "versions": [
        "4.6.0-3",
        "5.0.0-1",
        "5.1.1-1",
        "5.2.0-1",
        "5.2.0-2"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-25638",
      "fixed_version": "",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2022-25638",
      "provider_updated_at": "2026-04-22T13:19:06.169884Z"
    }
  ]
}

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

[Debian 12 (Bookworm)]

  • [libwolfssl35]Unknown

    Source package: [wolfssl]

    Details (4)
    • 5.5.4-2+deb12u2 · amd64 · bookworm

      Fixed · Fixed: 5.2.0-1

      dsa · wolfssl · debian · bookworm

    • 5.5.4-2+deb12u2 · arm64 · bookworm

      Fixed · Fixed: 5.2.0-1

      dsa · wolfssl · debian · bookworm

    • 5.5.4-2+deb12u3 · amd64 · bookworm-security

      Fixed · Fixed: 5.2.0-1

      dsa · wolfssl · debian · bookworm

    • 5.5.4-2+deb12u3 · arm64 · bookworm-security

      Fixed · Fixed: 5.2.0-1

      dsa · wolfssl · debian · bookworm

  • Source package: [wolfssl]

    Details (4)
    • 5.5.4-2+deb12u2 · amd64 · bookworm

      Fixed · Fixed: 5.2.0-1

      dsa · wolfssl · debian · bookworm

    • 5.5.4-2+deb12u2 · arm64 · bookworm

      Fixed · Fixed: 5.2.0-1

      dsa · wolfssl · debian · bookworm

    • 5.5.4-2+deb12u3 · amd64 · bookworm-security

      Fixed · Fixed: 5.2.0-1

      dsa · wolfssl · debian · bookworm

    • 5.5.4-2+deb12u3 · arm64 · bookworm-security

      Fixed · Fixed: 5.2.0-1

      dsa · wolfssl · debian · bookworm

Observed:

References