CVE catalog

CVE-2022-25648

ruby-git: CVE-2022-25648

[CVE catalog]

Severity
Critical · CVSS 9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
4.91% · Oct 25, 2026

The package git before 1.11.0 are vulnerable to Command Injection via git argument injection. When calling the fetch(remote = 'origin', opts = {}) function, the remote parameter is passed to the git fetch subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-gitsid5.6.0-1fixed
Debianruby-gitforky5.6.0-1fixed
Debianruby-gittrixie1.13.1-1fixed
Debianruby-gitbookworm1.13.1-1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-gitsourcesid1.13.1-1not yet assignedNot reported[1009926]
Debianruby-gitsourceforky1.13.1-1not yet assignedNot reported[1009926]
Debianruby-gitsourcetrixie1.13.1-1not yet assignedNot reported[1009926]
Debianruby-gitsourcebookworm1.13.1-1not yet assignedNot reported[1009926]

[Debian bug #1009926]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ruby-git]Fixed
    Details (2)
    • 1.13.1-1 · all · bookworm

      Fixed · Fixed: 1.13.1-1

      dsa · ruby-git · debian · bookworm

    • 1.13.1-1 · all · bookworm

      Fixed · Fixed: 1.13.1-1

      dsa · ruby-git · debian · bookworm

Observed:

References