CVE catalog

CVE-2022-25844

AngularJS vulnerabilities

[CVE catalog]

The package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom locale rule that makes it possible to assign the parameter in posPre: ' '.repeat() of NUMBER_FORMATS.PATTERNS[1].posPre with a very high value. **Note:** 1) This package has been deprecated and is no longer maintained. 2) The vulnerable versions are 1.7.0 and higher.

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
4.93% · Oct 27, 2026

Projects and upstream resources

Reported versions and fixes

Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.

Distribution / releasePackageVersionStatusSource
Debiantrixieangular.js1.8.3-2FixedDistribution-reported fixed boundary[CVE-2022-25844]
Debiantrixieangular.js1.8.3-3Fixed[CVE-2022-25844]
Debiansidangular.js1.8.3-2FixedDistribution-reported fixed boundary[CVE-2022-25844]
Debiansidangular.js1.8.3-3Fixed[CVE-2022-25844]
Debianbookwormangular.js1.8.3-1+deb12u1FixedDistribution-reported fixed boundary[CVE-2022-25844]

Showing 5 fix observations. All 14 observations, including unknown and conflicting reports, are available below.

Provider details and historical evidence
Distribution / releasePackageVersionStatusSource
UnknownRelease not reportedangular.js1.8.3-1ubuntu0.24.04.1UnknownSource applicability is not establishedProvider not reported
UnknownRelease not reportedlibjs-angularjs1.8.3-1ubuntu0.24.04.1UnknownSource applicability is not establishedProvider not reported
Debianbookwormangular.js1.8.3-1+deb12u1FixedDistribution-reported fixed boundary[CVE-2022-25844]
Debiansidangular.js1.8.3-2FixedDistribution-reported fixed boundary[CVE-2022-25844]
Debiansidangular.js1.8.3-3Fixed[CVE-2022-25844]
Debiantrixieangular.js1.8.3-2FixedDistribution-reported fixed boundary[CVE-2022-25844]
Debiantrixieangular.js1.8.3-3Fixed[CVE-2022-25844]
Ubuntu22.04angular.js1.8.2-2UnknownSource applicability is not established[UBUNTU-CVE-2022-25844]
Ubuntu22.04angular.js1.8.2-2ubuntu0.1UnknownSource applicability is not established[UBUNTU-CVE-2022-25844]
Ubuntu24.04angular.js1.8.3-1UnknownSource applicability is not established[UBUNTU-CVE-2022-25844]
Ubuntu24.04angular.js1.8.3-1ubuntu0.24.04.1UnknownSource applicability is not established[UBUNTU-CVE-2022-25844]
Ubuntuproangular.js1.5.10-1UnknownSource applicability is not established[UBUNTU-CVE-2022-25844]
Ubuntuproangular.js1.7.9-1UnknownSource applicability is not established[UBUNTU-CVE-2022-25844]
Ubuntuproangular.js1.7.9-1ubuntu0.1~esm1UnknownSource applicability is not established[UBUNTU-CVE-2022-25844]
Original provider fields
{
  "package_releases": [
    {
      "name": "angular.js",
      "status": "fixed",
      "release": "sid",
      "version": "1.8.3-3"
    },
    {
      "name": "angular.js",
      "status": "fixed",
      "release": "trixie",
      "version": "1.8.3-3"
    },
    {
      "name": "angular.js",
      "status": "fixed",
      "release": "bookworm",
      "version": "1.8.3-1+deb12u1"
    }
  ],
  "fixed_versions": [
    {
      "bug": 1014779,
      "name": "angular.js",
      "type": "source",
      "origin": null,
      "release": "sid",
      "urgency": "not yet assigned",
      "fixed_version": "1.8.3-2"
    },
    {
      "bug": 1014779,
      "name": "angular.js",
      "type": "source",
      "origin": null,
      "release": "trixie",
      "urgency": "not yet assigned",
      "fixed_version": "1.8.3-2"
    },
    {
      "bug": 1014779,
      "name": "angular.js",
      "type": "source",
      "origin": null,
      "release": "bookworm",
      "urgency": "not yet assigned",
      "fixed_version": "1.8.3-1+deb12u1"
    }
  ],
  "distribution_packages": [
    {
      "name": "angular.js",
      "fixed_version": "1.8.3-1ubuntu0.24.04.1",
      "applicability_unknown": true
    },
    {
      "name": "libjs-angularjs",
      "fixed_version": "1.8.3-1ubuntu0.24.04.1",
      "applicability_unknown": true
    },
    {
      "name": "angular.js",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.7.9-1ubuntu0.1~esm1"
            }
          ]
        }
      ],
      "release": "pro",
      "versions": [
        "1.5.10-1",
        "1.7.9-1"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-25844",
      "fixed_version": "1.7.9-1ubuntu0.1~esm1",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2022-25844",
      "provider_updated_at": "2026-02-04T02:58:32.077143Z",
      "applicability_unknown": true
    },
    {
      "name": "angular.js",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.8.2-2ubuntu0.1"
            }
          ]
        }
      ],
      "release": "22.04",
      "versions": [
        "1.8.2-2"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-25844",
      "fixed_version": "1.8.2-2ubuntu0.1",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2022-25844",
      "provider_updated_at": "2026-02-04T02:58:32.077143Z",
      "applicability_unknown": true
    },
    {
      "name": "angular.js",
      "distro": "ubuntu",
      "ranges": [
        {
          "type": "ECOSYSTEM",
          "events": [
            {
              "introduced": "0"
            },
            {
              "fixed": "1.8.3-1ubuntu0.24.04.1"
            }
          ]
        }
      ],
      "release": "24.04",
      "versions": [
        "1.8.3-1"
      ],
      "ecosystem": "deb",
      "provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-25844",
      "fixed_version": "1.8.3-1ubuntu0.24.04.1",
      "provider_source": "pypi",
      "provider_record_id": "UBUNTU-CVE-2022-25844",
      "provider_updated_at": "2026-02-04T02:58:32.077143Z",
      "applicability_unknown": true
    }
  ]
}

[Debian bug #1014779]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [angular.js]

    Details (2)
    • 1.8.3-1+deb12u1 · all · bookworm

      Unknown · Fixed: 1.8.3-1+deb12u1, 1.8.3-1+deb12u1~deb11u1

      Version impact unknown

      usn · angular.js · debian · bookworm; pypi · angular.js · debian · 11

    • 1.8.3-1+deb12u1 · all · bookworm

      Unknown · Fixed: 1.8.3-1+deb12u1, 1.8.3-1+deb12u1~deb11u1

      Version impact unknown

      usn · angular.js · debian · bookworm; pypi · angular.js · debian · 11

[Debian 13 (Trixie)]

  • Source package: [angular.js]

    Details (2)
    • 1.8.3-3 · all · trixie

      Unknown · Fixed: 1.8.3-1+deb12u1, 1.8.3-1+deb12u1~deb11u1

      Version impact unknown

      usn · angular.js · debian · bookworm; pypi · angular.js · debian · 11

    • 1.8.3-3 · all · trixie

      Unknown · Fixed: 1.8.3-1+deb12u1, 1.8.3-1+deb12u1~deb11u1

      Version impact unknown

      usn · angular.js · debian · bookworm; pypi · angular.js · debian · 11

Observed:

References