CVE catalog

CVE-2022-25858

node-terser: CVE-2022-25858

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
3.25% · Oct 25, 2026

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-tersersid5.51.2-2fixed
Debiannode-terserforky5.51.2-2fixed
Debiannode-tersertrixie5.38.0-1fixed
Debiannode-terserbookworm5.16.5-2fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-tersersourcesid4.8.1-1not yet assignedNot reportedNot reported
Debiannode-tersersourceforky4.8.1-1not yet assignedNot reportedNot reported
Debiannode-tersersourcetrixie4.8.1-1not yet assignedNot reportedNot reported
Debiannode-tersersourcebookworm4.8.1-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Source package: [node-terser]

    Details (2)
    • 5.16.5-2 · all · bookworm

      Fixed · Fixed: 4.8.1-1

      dsa · node-terser · debian · bookworm

    • 5.16.5-2 · all · bookworm

      Fixed · Fixed: 4.8.1-1

      dsa · node-terser · debian · bookworm

  • Details (2)
    • 5.16.5-2 · all · bookworm

      Fixed · Fixed: 4.8.1-1

      dsa · node-terser · debian · bookworm

    • 5.16.5-2 · all · bookworm

      Fixed · Fixed: 4.8.1-1

      dsa · node-terser · debian · bookworm

  • [terser]Fixed

    Source package: [node-terser]

    Details (2)
    • 5.16.5-2 · all · bookworm

      Fixed · Fixed: 4.8.1-1

      dsa · node-terser · debian · bookworm

    • 5.16.5-2 · all · bookworm

      Fixed · Fixed: 4.8.1-1

      dsa · node-terser · debian · bookworm

Observed:

References