
CVE catalog
CVE-2022-25887
Jupyter Notebook vulnerability
The package sanitize-html before 2.7.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure global regular expression replacement logic of HTML comment removal.
- Severity
- Medium · CVSS 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.55% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debiantrixie | node-sanitize-html | 2.14.0+~2.13.0-1 | Fixed | [CVE-2022-25887] |
| Debiantrixie | node-sanitize-html | 2.7.1+~2.6.2-1 | FixedDistribution-reported fixed boundary | [CVE-2022-25887] |
| Debiansid | node-sanitize-html | 2.17.0+~2.16.1-1 | Fixed | [CVE-2022-25887] |
| Debiansid | node-sanitize-html | 2.7.1+~2.6.2-1 | FixedDistribution-reported fixed boundary | [CVE-2022-25887] |
| Debianforky | node-sanitize-html | 2.17.0+~2.16.1-1 | Fixed | [CVE-2022-25887] |
| Debianforky | node-sanitize-html | 2.7.1+~2.6.2-1 | FixedDistribution-reported fixed boundary | [CVE-2022-25887] |
| Debianbookworm | node-sanitize-html | 2.7.1+~2.6.2-1 | FixedDistribution-reported fixed boundary | [CVE-2022-25887] |
| Debianbookworm | node-sanitize-html | 2.8.0+~2.6.2-1 | Fixed | [CVE-2022-25887] |
Showing 8 fix observations. All 15 observations, including unknown and conflicting reports, are available below.
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| UnknownRelease not reported | jupyter-notebook | 6.4.12-2.2ubuntu1+esm1 | UnknownSource applicability is not established | Provider not reported |
| UnknownRelease not reported | python-notebook-doc | 6.4.12-2.2ubuntu1+esm1 | UnknownSource applicability is not established | Provider not reported |
| UnknownRelease not reported | python3-notebook | 6.4.12-2.2ubuntu1+esm1 | UnknownSource applicability is not established | Provider not reported |
| NpmRelease not reported | sanitize-html | 2.7.1 | UnknownSource applicability is not established | Provider not reported |
| Debianbookworm | node-sanitize-html | 2.7.1+~2.6.2-1 | FixedDistribution-reported fixed boundary | [CVE-2022-25887] |
| Debianbookworm | node-sanitize-html | 2.8.0+~2.6.2-1 | Fixed | [CVE-2022-25887] |
| Debianforky | node-sanitize-html | 2.17.0+~2.16.1-1 | Fixed | [CVE-2022-25887] |
| Debianforky | node-sanitize-html | 2.7.1+~2.6.2-1 | FixedDistribution-reported fixed boundary | [CVE-2022-25887] |
| Debiansid | node-sanitize-html | 2.17.0+~2.16.1-1 | Fixed | [CVE-2022-25887] |
| Debiansid | node-sanitize-html | 2.7.1+~2.6.2-1 | FixedDistribution-reported fixed boundary | [CVE-2022-25887] |
| Debiantrixie | node-sanitize-html | 2.14.0+~2.13.0-1 | Fixed | [CVE-2022-25887] |
| Debiantrixie | node-sanitize-html | 2.7.1+~2.6.2-1 | FixedDistribution-reported fixed boundary | [CVE-2022-25887] |
| Ubuntupro | jupyter-notebook | 6.4.12-2.2 | UnknownSource applicability is not established | [USN-7464-1] |
| Ubuntupro | jupyter-notebook | 6.4.12-2.2ubuntu1 | UnknownSource applicability is not established | [USN-7464-1] |
| Ubuntupro | jupyter-notebook | 6.4.12-2.2ubuntu1+esm1 | UnknownSource applicability is not established | [USN-7464-1] |
Original provider fields
{
"package_releases": [
{
"name": "node-sanitize-html",
"status": "fixed",
"release": "sid",
"version": "2.17.0+~2.16.1-1"
},
{
"name": "node-sanitize-html",
"status": "fixed",
"release": "forky",
"version": "2.17.0+~2.16.1-1"
},
{
"name": "node-sanitize-html",
"status": "fixed",
"release": "trixie",
"version": "2.14.0+~2.13.0-1"
},
{
"name": "node-sanitize-html",
"status": "fixed",
"release": "bookworm",
"version": "2.8.0+~2.6.2-1"
}
],
"fixed_versions": [
{
"bug": 1019219,
"name": "node-sanitize-html",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "2.7.1+~2.6.2-1"
},
{
"bug": 1019219,
"name": "node-sanitize-html",
"type": "source",
"origin": null,
"release": "forky",
"urgency": "not yet assigned",
"fixed_version": "2.7.1+~2.6.2-1"
},
{
"bug": 1019219,
"name": "node-sanitize-html",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "not yet assigned",
"fixed_version": "2.7.1+~2.6.2-1"
},
{
"bug": 1019219,
"name": "node-sanitize-html",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": "2.7.1+~2.6.2-1"
}
],
"distribution_packages": [
{
"name": "jupyter-notebook",
"fixed_version": "6.4.12-2.2ubuntu1+esm1",
"applicability_unknown": true
},
{
"name": "python-notebook-doc",
"fixed_version": "6.4.12-2.2ubuntu1+esm1",
"applicability_unknown": true
},
{
"name": "python3-notebook",
"fixed_version": "6.4.12-2.2ubuntu1+esm1",
"applicability_unknown": true
},
{
"name": "sanitize-html",
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.7.1"
}
]
}
],
"ecosystem": "npm",
"fixed_version": "2.7.1",
"applicability_unknown": true
},
{
"name": "jupyter-notebook",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "6.4.12-2.2ubuntu1+esm1"
}
]
}
],
"release": "pro",
"versions": [
"6.4.12-2.2",
"6.4.12-2.2ubuntu1"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/USN-7464-1",
"fixed_version": "6.4.12-2.2ubuntu1+esm1",
"provider_source": "pypi",
"provider_record_id": "USN-7464-1",
"provider_updated_at": "2026-04-27T17:55:25.497358Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [node-sanitize-html]Unknown
Details (2)
2.8.0+~2.6.2-1· all · bookwormFixed · Fixed:
2.7.1+~2.6.2-1usn · node-sanitize-html · debian · bookworm
2.8.0+~2.6.2-1· all · bookwormFixed · Fixed:
2.7.1+~2.6.2-1usn · node-sanitize-html · debian · bookworm
Observed:
References
- [https://osv.dev/vulnerability/GHSA-cgfm-xwp7-2cvr]
- [https://osv.dev/vulnerability/USN-7464-1]
- [https://security-tracker.debian.org/tracker/CVE-2022-25887]
- [https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-25887.json]
- [https://ubuntu.com/security/notices/USN-7464-1]
- [https://wid.cert-bund.de/.well-known/csaf/white/2022/wid-sec-w-2022-2368.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [Ubuntu Security Notices (USN)]