
CVE catalog
CVE-2022-28366
libowasp-antisamy-java: CVE-2022-28366
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.17% · Oct 25, 2026
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | libowasp-antisamy-java | sid | 1.7.8-1 | fixed |
| Debian | libowasp-antisamy-java | forky | 1.7.4-1 | fixed |
| Debian | libowasp-antisamy-java | trixie | 1.7.4-1 | fixed |
| Debian | libowasp-antisamy-java | bookworm | 1.5.3+dfsg-1.1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | libowasp-antisamy-java | source | sid | 1.7.4-1 | not yet assigned | Not reported | [1010154] |
| Debian | libowasp-antisamy-java | source | forky | 1.7.4-1 | not yet assigned | Not reported | [1010154] |
| Debian | libowasp-antisamy-java | source | trixie | 1.7.4-1 | not yet assigned | Not reported | [1010154] |
| Debian | libowasp-antisamy-java | source | bookworm | (unfixed) | not yet assigned | Not reported | [1010154] |
Notes
[bookworm] libowasp-antisamy-java: Minor issue
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [libowasp-antisamy-java]Affected
Details (2)
1.5.3+dfsg-1.1· all · bookwormAffected
dsa · libowasp-antisamy-java · debian · bookworm
1.5.3+dfsg-1.1· all · bookwormAffected
dsa · libowasp-antisamy-java · debian · bookworm
- [libowasp-antisamy-java-doc]Affected
Source package: [libowasp-antisamy-java]
Details (2)
1.5.3+dfsg-1.1· all · bookwormAffected
dsa · libowasp-antisamy-java · debian · bookworm
1.5.3+dfsg-1.1· all · bookwormAffected
dsa · libowasp-antisamy-java · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_12022-1.json]
- [https://security-tracker.debian.org/tracker/CVE-2022-28366]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-2993.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [SUSE security advisories and VEX]