CVE catalog

CVE-2022-30688

needrestart: CVE-2022-30688

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
0.39% · Oct 25, 2026

needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianneedrestartsid3.11-1fixed
Debianneedrestartforky3.11-1fixed
Debianneedrestarttrixie3.11-1fixed
Debianneedrestartbookworm3.6-4+deb12u3fixed
Debianneedrestartbookworm-security3.6-4+deb12u3fixed
Ubuntuneedrestart18.042.11-4vulnerable
Ubuntuneedrestart18.043.0-1vulnerable
Ubuntuneedrestart18.043.1-1vulnerable
Ubuntuneedrestart18.043.1-1ubuntu0.1fixed
Ubuntuneedrestart20.043.4-5vulnerable
Ubuntuneedrestart20.043.4-6vulnerable
Ubuntuneedrestart20.043.4-6ubuntu0.1fixed
Ubuntuneedrestart22.043.5-4ubuntu2vulnerable
Ubuntuneedrestart22.043.5-5ubuntu1vulnerable
Ubuntuneedrestart22.043.5-5ubuntu2vulnerable
Ubuntuneedrestart22.043.5-5ubuntu2.1fixed
Ubuntuneedrestartpro2.1-1vulnerable
Ubuntuneedrestartpro2.3-2vulnerable
Ubuntuneedrestartpro2.4-1vulnerable
Ubuntuneedrestartpro2.5-1vulnerable
Ubuntuneedrestartpro2.6-1vulnerable
Ubuntuneedrestartpro2.6-1ubuntu0.1~esm1vulnerable
Ubuntuneedrestartpro2.6-1ubuntu0.1~esm2vulnerable
Ubuntuneedrestartpro2.6-1ubuntu0.1~esm3vulnerable
Ubuntuneedrestart18.042.11-4vulnerable
Ubuntuneedrestart18.043.0-1vulnerable
Ubuntuneedrestart18.043.1-1vulnerable
Ubuntuneedrestart18.043.1-1ubuntu0.1fixed
Ubuntuneedrestart20.043.4-5vulnerable
Ubuntuneedrestart20.043.4-6vulnerable
Ubuntuneedrestart20.043.4-6ubuntu0.1fixed
Ubuntuneedrestart22.043.5-4ubuntu2vulnerable
Ubuntuneedrestart22.043.5-5ubuntu1vulnerable
Ubuntuneedrestart22.043.5-5ubuntu2vulnerable
Ubuntuneedrestart22.043.5-5ubuntu2.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianneedrestartsourcesid3.6-1not yet assignedNot reported[1011154]
Debianneedrestartsourceforky3.6-1not yet assignedNot reported[1011154]
Debianneedrestartsourcetrixie3.6-1not yet assignedNot reported[1011154]
Debianneedrestartsourcebookworm3.6-1not yet assignedNot reported[1011154]
Ubuntuneedrestartdeb18.043.1-1ubuntu0.1Not reportedUSN-5426-1Not reported
Ubuntuneedrestartdeb20.043.4-6ubuntu0.1Not reportedUSN-5426-1Not reported
Ubuntuneedrestartdeb22.043.5-5ubuntu2.1Not reportedUSN-5426-1Not reported
Ubuntuneedrestartdeb18.043.1-1ubuntu0.1Not reportedUBUNTU-CVE-2022-30688Not reported
Ubuntuneedrestartdeb20.043.4-6ubuntu0.1Not reportedUBUNTU-CVE-2022-30688Not reported
Ubuntuneedrestartdeb22.043.5-5ubuntu2.1Not reportedUBUNTU-CVE-2022-30688Not reported

[Debian bug #1011154]

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • Details (6)
    • 3.6-4+deb12u3 · all · bookworm

      Fixed · Fixed: 3.6-1

      dsa · needrestart · debian · bookworm

    • 3.6-4+deb12u3 · all · bookworm

      Fixed · Fixed: 3.6-1

      dsa · needrestart · debian · bookworm

    • 3.8-2~bpo12+1 · all · bookworm-backports

      Fixed · Fixed: 3.6-1

      dsa · needrestart · debian · bookworm

    • 3.8-2~bpo12+1 · all · bookworm-backports

      Fixed · Fixed: 3.6-1

      dsa · needrestart · debian · bookworm

    • 3.6-4+deb12u3 · all · bookworm-security

      Fixed · Fixed: 3.6-1

      dsa · needrestart · debian · bookworm

    • 3.6-4+deb12u3 · all · bookworm-security

      Fixed · Fixed: 3.6-1

      dsa · needrestart · debian · bookworm

Observed:

References