
CVE catalog
CVE-2022-31052
matrix-synapse-1.61.1-1.1 on GA media
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.66% · Oct 25, 2026
Synapse is an open source home server implementation for the Matrix chat network. In versions prior to 1.61.1 URL previews of some web pages can exhaust the available stack space for the Synapse process due to unbounded recursion. This is sometimes recoverable and leads to an error for the request causing the problem, but in other cases the Synapse process may crash altogether. It is possible to exploit this maliciously, either by malicious users on the homeserver, or by remote users sending URLs that a local user's client may automatically request a URL preview for. Remote users are not able to exploit this directly, because the URL preview endpoint is authenticated. Deployments with `url_preview_enabled: false` set in configuration are not affected. Deployments with `url_preview_enabled: true` set in configuration **are** affected. Deployments with no configuration value set for `url_preview_enabled` are not affected, because the default is `false`. Administrators of homeservers with URL previews enabled are advised to upgrade to v1.61.1 or higher. Users unable to upgrade should set `url_preview_enabled` to false.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | matrix-synapse | pro | 0.19.2+dfsg-6 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1ubuntu0.1~esm4 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.3.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.4.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.5.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.5.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.6.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.6.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.3-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.8.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.9.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.9.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.10.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.10.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.11.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.11.0-1ubuntu0.1~esm2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.39.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.47.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.47.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.48.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.49.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.49.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.50.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.50.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.51.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.52.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.53.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.53.0-1ubuntu0.1~esm2 | vulnerable |
| Opensuse | matrix-synapse | tumbleweed | 1.61.1-1.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Opensuse | matrix-synapse | rpm | tumbleweed | 1.61.1-1.1 | Not reported | OPENSUSE-SU-2024:12160-1 | Not reported |
OpenFactory catalog packages
[openSUSE Tumbleweed]
- [matrix-synapse]Fixed
Source package: [matrix-synapse]
Details (1)
1.159.0-1.2· x86_64 · tumbleweedFixed · Fixed:
1.61.1-1.1pypi · matrix-synapse · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_12160-1.json]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-31052]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:12160-1]
- [https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-31052.json]
[FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]