
CVE catalog
CVE-2022-31147
UBUNTU-CVE-2022-31147
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 2.24% · Oct 25, 2026
The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | civicrm | pro | 4.7.1+dfsg-1 | vulnerable |
| Ubuntu | civicrm | pro | 4.7.1+dfsg-2 | vulnerable |
| Ubuntu | civicrm | pro | 4.7.1+dfsg-2ubuntu1 | vulnerable |
| Ubuntu | civicrm | pro | 4.7.1+dfsg-2ubuntu1+esm1 | vulnerable |
| Ubuntu | civicrm | pro | 4.7.23+dfsg-1ubuntu1 | vulnerable |
| Ubuntu | civicrm | pro | 4.7.24+dfsg-1ubuntu1 | vulnerable |
| Ubuntu | civicrm | pro | 4.7.30+dfsg-1ubuntu1 | vulnerable |
| Ubuntu | civicrm | pro | 4.7.30+dfsg-1ubuntu1+esm1 | vulnerable |
| Ubuntu | civicrm | pro | 5.11.0+dfsg-1 | vulnerable |
| Ubuntu | civicrm | pro | 5.18.1+dfsg-1 | vulnerable |
| Ubuntu | civicrm | pro | 5.20.3+dfsg-1 | vulnerable |
| Ubuntu | civicrm | pro | 5.21.0+dfsg-1 | vulnerable |
| Ubuntu | civicrm | pro | 5.21.1+dfsg-1 | vulnerable |
| Ubuntu | civicrm | pro | 5.21.2+dfsg-1 | vulnerable |
| Ubuntu | civicrm | pro | 5.21.2+dfsg-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | civicrm | pro | 5.33.2+dfsg1-1 | vulnerable |
| Ubuntu | civicrm | pro | 5.33.2+dfsg1-1build1 | vulnerable |
| Ubuntu | civicrm | pro | 5.33.2+dfsg1-1ubuntu1 | vulnerable |
| Ubuntu | civicrm | pro | 5.33.2+dfsg1-1ubuntu1+esm1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: