
CVE catalog
CVE-2022-31152
UBUNTU-CVE-2022-31152
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 1.18% · Oct 25, 2026
Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. The Matrix specification specifies a list of [event authorization rules](https://spec.matrix.org/v1.2/rooms/v9/#authorization-rules) which must be checked when determining if an event should be accepted into a room. In versions of Synapse up to and including version 1.61.0, some of these rules are not correctly applied. An attacker could craft events which would be accepted by Synapse but not a spec-conformant server, potentially causing divergence in the room state between servers. Administrators of homeservers with federation enabled are advised to upgrade to version 1.62.0 or higher. Federation can be disabled by setting [`federation_domain_whitelist`](https://matrix-org.github.io/synapse/latest/usage/configuration/config_documentation.html#federation_domain_whitelist) to an empty list (`[]`) as a workaround.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | matrix-synapse | pro | 0.19.2+dfsg-6 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1ubuntu0.1~esm4 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.3.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.4.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.5.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.5.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.6.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.6.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.3-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.8.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.9.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.9.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.10.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.10.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.11.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.11.0-1ubuntu0.1~esm2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.39.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.47.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.47.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.48.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.49.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.49.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.50.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.50.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.51.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.52.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.53.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.53.0-1ubuntu0.1~esm2 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
No matching packages in this catalog.
Observed: