
CVE catalog
CVE-2022-3517
node-minimatch affected and fixed versions
A vulnerability was found in the minimatch package. This flaw allows a Regular Expression Denial of Service (ReDoS) when calling the braceExpand function with specific arguments, resulting in a Denial of Service.
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 2.28% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| Debiantrixie | node-minimatch | 3.0.5+~3.0.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-3517] |
| Debiantrixie | node-minimatch | 9.0.3-6 | Fixed | [CVE-2022-3517] |
| Debiansid | node-minimatch | 3.0.5+~3.0.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-3517] |
| Debiansid | node-minimatch | 9.0.7-2 | Fixed | [CVE-2022-3517] |
| Debianforky | node-minimatch | 3.0.5+~3.0.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-3517] |
| Debianforky | node-minimatch | 9.0.7-2 | Fixed | [CVE-2022-3517] |
| Debianbookworm | node-minimatch | 3.0.5+~3.0.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-3517] |
| Debianbookworm | node-minimatch | 5.1.1+~5.1.2-1 | Fixed | [CVE-2022-3517] |
Showing 8 fix observations. All 15 observations, including unknown and conflicting reports, are available below.
Provider details and historical evidence
| Distribution / release | Package | Version | Status | Source |
|---|---|---|---|---|
| NpmRelease not reported | minimatch | 3.0.5 | UnknownSource applicability is not established | [GHSA-F8Q6-P94X-37V3] |
| Debianbookworm | node-minimatch | 3.0.5+~3.0.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-3517] |
| Debianbookworm | node-minimatch | 5.1.1+~5.1.2-1 | Fixed | [CVE-2022-3517] |
| Debianforky | node-minimatch | 3.0.5+~3.0.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-3517] |
| Debianforky | node-minimatch | 9.0.7-2 | Fixed | [CVE-2022-3517] |
| Debiansid | node-minimatch | 3.0.5+~3.0.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-3517] |
| Debiansid | node-minimatch | 9.0.7-2 | Fixed | [CVE-2022-3517] |
| Debiantrixie | node-minimatch | 3.0.5+~3.0.5-1 | FixedDistribution-reported fixed boundary | [CVE-2022-3517] |
| Debiantrixie | node-minimatch | 9.0.3-6 | Fixed | [CVE-2022-3517] |
| Ubuntu18.04 | node-minimatch | 3.0.4-1 | UnknownSource applicability is not established | [USN-6086-1][UBUNTU-CVE-2022-3517] |
| Ubuntu18.04 | node-minimatch | 3.0.4-3 | UnknownSource applicability is not established | [USN-6086-1][UBUNTU-CVE-2022-3517] |
| Ubuntu18.04 | node-minimatch | 3.0.4-3+deb10u1build0.18.04.1 | UnknownSource applicability is not established | [USN-6086-1][UBUNTU-CVE-2022-3517] |
| Ubuntu20.04 | node-minimatch | 3.0.4-3 | UnknownSource applicability is not established | [USN-6086-1][UBUNTU-CVE-2022-3517] |
| Ubuntu20.04 | node-minimatch | 3.0.4-4 | UnknownSource applicability is not established | [USN-6086-1][UBUNTU-CVE-2022-3517] |
| Ubuntu20.04 | node-minimatch | 3.0.4-4ubuntu0.1 | UnknownSource applicability is not established | [USN-6086-1][UBUNTU-CVE-2022-3517] |
Original provider fields
{
"package_releases": [
{
"name": "node-minimatch",
"status": "fixed",
"release": "sid",
"version": "9.0.7-2"
},
{
"name": "node-minimatch",
"status": "fixed",
"release": "forky",
"version": "9.0.7-2"
},
{
"name": "node-minimatch",
"status": "fixed",
"release": "trixie",
"version": "9.0.3-6"
},
{
"name": "node-minimatch",
"status": "fixed",
"release": "bookworm",
"version": "5.1.1+~5.1.2-1"
}
],
"fixed_versions": [
{
"bug": null,
"name": "node-minimatch",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "3.0.5+~3.0.5-1"
},
{
"bug": null,
"name": "node-minimatch",
"type": "source",
"origin": null,
"release": "forky",
"urgency": "not yet assigned",
"fixed_version": "3.0.5+~3.0.5-1"
},
{
"bug": null,
"name": "node-minimatch",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "not yet assigned",
"fixed_version": "3.0.5+~3.0.5-1"
},
{
"bug": null,
"name": "node-minimatch",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": "3.0.5+~3.0.5-1"
}
],
"distribution_packages": [
{
"name": "minimatch",
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.5"
}
]
}
],
"ecosystem": "npm",
"provider_url": "https://osv.dev/vulnerability/GHSA-f8q6-p94x-37v3",
"fixed_version": "3.0.5",
"provider_source": "pypi",
"provider_record_id": "GHSA-F8Q6-P94X-37V3",
"provider_updated_at": "2026-07-08T18:29:36.290089494Z",
"applicability_unknown": true
},
{
"name": "node-minimatch",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.4-3+deb10u1build0.18.04.1"
}
]
}
],
"release": "18.04",
"versions": [
"3.0.4-1",
"3.0.4-3"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/USN-6086-1",
"fixed_version": "3.0.4-3+deb10u1build0.18.04.1",
"provider_source": "pypi",
"provider_record_id": "USN-6086-1",
"provider_updated_at": "2026-02-10T04:43:08Z",
"applicability_unknown": true
},
{
"name": "node-minimatch",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.4-4ubuntu0.1"
}
]
}
],
"release": "20.04",
"versions": [
"3.0.4-3",
"3.0.4-4"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/USN-6086-1",
"fixed_version": "3.0.4-4ubuntu0.1",
"provider_source": "pypi",
"provider_record_id": "USN-6086-1",
"provider_updated_at": "2026-02-10T04:43:08Z",
"applicability_unknown": true
},
{
"name": "node-minimatch",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.4-3+deb10u1build0.18.04.1"
}
]
}
],
"release": "18.04",
"versions": [
"3.0.4-1",
"3.0.4-3"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-3517",
"fixed_version": "3.0.4-3+deb10u1build0.18.04.1",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2022-3517",
"provider_updated_at": "2026-02-04T02:53:12.042796Z",
"applicability_unknown": true
},
{
"name": "node-minimatch",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.4-4ubuntu0.1"
}
]
}
],
"release": "20.04",
"versions": [
"3.0.4-3",
"3.0.4-4"
],
"ecosystem": "deb",
"provider_url": "https://osv.dev/vulnerability/UBUNTU-CVE-2022-3517",
"fixed_version": "3.0.4-4ubuntu0.1",
"provider_source": "pypi",
"provider_record_id": "UBUNTU-CVE-2022-3517",
"provider_updated_at": "2026-02-04T02:53:12.042796Z",
"applicability_unknown": true
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [node-minimatch]Unknown
Details (2)
5.1.1+~5.1.2-1· all · bookwormFixed · Fixed:
3.0.5+~3.0.5-1dsa · node-minimatch · debian · bookworm
5.1.1+~5.1.2-1· all · bookwormFixed · Fixed:
3.0.5+~3.0.5-1dsa · node-minimatch · debian · bookworm
Observed:
References
- [https://access.redhat.com/errata/RHSA-2023:3742]
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2022_8833.json]
- [https://osv.dev/vulnerability/DLA-3271-1]
- [https://osv.dev/vulnerability/GHSA-f8q6-p94x-37v3]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-3517]
- [https://osv.dev/vulnerability/USN-6086-1]
- [https://security-tracker.debian.org/tracker/CVE-2022-3517]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-1350.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]