CVE catalog

CVE-2022-4064

ruby-dalli: CVE-2022-4064

[CVE catalog]

Severity
Low
Source
[NVD] · [CVE record]
EPSS
1.40% · Oct 25, 2026

A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-dallisid5.2.1-1not affected
Debianruby-dalliforky5.2.1-1not affected
Debianruby-dallitrixie3.2.8-2not affected
Debianruby-dallibookworm3.0.6-1.1not affected

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-dallisourcesidNot affectedunimportantNot reportedNot reported
Debianruby-dallisourceforkyNot affectedunimportantNot reportedNot reported
Debianruby-dallisourcetrixieNot affectedunimportantNot reportedNot reported
Debianruby-dallisourcebookwormNot affectedunimportantNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ruby-dalli]Not affected
    Details (2)
    • 3.0.6-1.1 · all · bookworm

      Not affected

      dsa · ruby-dalli · debian · bookworm

    • 3.0.6-1.1 · all · bookworm

      Not affected

      dsa · ruby-dalli · debian · bookworm

Observed:

References