
CVE catalog
CVE-2022-41881
netty: CVE-2022-41881
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.58% · Oct 25, 2026
Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | netty | sid | 1:4.1.48-16 | fixed |
| Debian | netty | forky | 1:4.1.48-16 | fixed |
| Debian | netty | trixie | 1:4.1.48-10+deb13u1 | fixed |
| Debian | netty | trixie-security | 1:4.1.48-10+deb13u1 | fixed |
| Debian | netty | bookworm | 1:4.1.48-7+deb12u2 | fixed |
| Debian | netty | bookworm-security | 1:4.1.48-7+deb12u2 | fixed |
| Ubuntu | netty | pro | 1:4.1.33-1 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.33-2 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.33-3 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.45-1 | vulnerable |
| Ubuntu | netty | pro | 1:4.1.45-1ubuntu0.1~esm1 | fixed |
| Ubuntu | netty-3.9 | 16.04 | 3.9.0.Final-1 | vulnerable |
| Ubuntu | netty-3.9 | 16.04 | 3.9.0.Final-1ubuntu0.1 | vulnerable |
| Ubuntu | netty-3.9 | 18.04 | 3.9.9.Final-1 | vulnerable |
| Ubuntu | netty-3.9 | 18.04 | 3.9.9.Final-1+deb9u1build0.18.04.1 | vulnerable |
| Ubuntu | netty | 22.04 | 1:4.1.48-4 | vulnerable |
| Ubuntu | netty | 22.04 | 1:4.1.48-4+deb11u1build0.22.04.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | netty | source | sid | 1:4.1.48-6 | not yet assigned | Not reported | [1027180] |
| Debian | netty | source | forky | 1:4.1.48-6 | not yet assigned | Not reported | [1027180] |
| Debian | netty | source | trixie | 1:4.1.48-6 | not yet assigned | Not reported | [1027180] |
| Debian | netty | source | bookworm | 1:4.1.48-6 | not yet assigned | Not reported | [1027180] |
| Ubuntu | netty | deb | pro | 1:4.1.45-1ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2022-41881 | Not reported |
| Ubuntu | netty | deb | 22.04 | 1:4.1.48-4+deb11u1build0.22.04.1 | Not reported | UBUNTU-CVE-2022-41881 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [libnetty-java]Unknown
Source package: [netty]
Details (4)
1:4.1.48-7+deb12u2· all · bookwormFixed · Fixed:
1:4.1.48-6dsa · netty · debian · bookworm
1:4.1.48-7+deb12u2· all · bookwormFixed · Fixed:
1:4.1.48-6dsa · netty · debian · bookworm
1:4.1.48-7+deb12u2· all · bookworm-securityFixed · Fixed:
1:4.1.48-6dsa · netty · debian · bookworm
1:4.1.48-7+deb12u2· all · bookworm-securityFixed · Fixed:
1:4.1.48-6dsa · netty · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2023_2096-1.json]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-41881]
- [https://security-tracker.debian.org/tracker/CVE-2022-41881]
- [https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-41881.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-1142.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]