
CVE catalog
CVE-2022-42889
commons-text: CVE-2022-42889
- Severity
- Critical · CVSS 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 99.93% · Oct 25, 2026
Apache Commons Text performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.text.lookup.StringLookup that performs the interpolation. Starting with version 1.5 and continuing through 1.9, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Text 1.10.0, which disables the problematic interpolators by default.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | commons-text | sid | 1.15.0-1 | fixed |
| Debian | commons-text | forky | 1.15.0-1 | fixed |
| Debian | commons-text | trixie | 1.13.1-1 | fixed |
| Debian | commons-text | bookworm | 1.10.0-1 | fixed |
| Opensuse | apache-commons-text | tumbleweed | 1.10.0-1.1 | fixed |
| Ubuntu | commons-text | 20.04 | 1.8-1 | vulnerable |
| Ubuntu | commons-text | 20.04 | 1.8-2 | vulnerable |
| Ubuntu | commons-text | 22.04 | 1.9-1 | vulnerable |
| Ubuntu | commons-text | 22.04 | 1.9-2 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | commons-text | source | sid | 1.10.0-1 | not yet assigned | Not reported | [1021787] |
| Debian | commons-text | source | forky | 1.10.0-1 | not yet assigned | Not reported | [1021787] |
| Debian | commons-text | source | trixie | 1.10.0-1 | not yet assigned | Not reported | [1021787] |
| Debian | commons-text | source | bookworm | 1.10.0-1 | not yet assigned | Not reported | [1021787] |
| Opensuse | apache-commons-text | rpm | tumbleweed | 1.10.0-1.1 | Not reported | OPENSUSE-SU-2024:12409-1 | Not reported |
OpenFactory catalog packages
[openSUSE Tumbleweed]
- [apache-commons-text-javadoc]Unknown
Source package: [apache-commons-text]
Details (1)
1.15.0-1.3· noarch · tumbleweedUnknown · Fixed:
1.10.0-1.1Version impact unknown
dsa · apache-commons-text · opensuse · tumbleweed
- [apache-commons-text]Fixed
Source package: [apache-commons-text]
Details (1)
1.15.0-1.3· noarch · tumbleweedFixed · Fixed:
1.10.0-1.1dsa · apache-commons-text · opensuse · tumbleweed
[Debian 12 (Bookworm)]
- [libcommons-text-java]Fixed
Source package: [commons-text]
Details (2)
1.10.0-1· all · bookwormFixed · Fixed:
1.10.0-1dsa · commons-text · debian · bookworm
1.10.0-1· all · bookwormFixed · Fixed:
1.10.0-1dsa · commons-text · debian · bookworm
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_12409-1.json]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2022-42889]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:12409-1]
- [https://security-tracker.debian.org/tracker/CVE-2022-42889]
- [https://security.access.redhat.com/data/csaf/v2/vex/2022/cve-2022-42889.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-1143.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]