CVE catalog

CVE-2022-47318

ruby-git: CVE-2022-47318

[CVE catalog]

Severity
High · CVSS 8CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Published
Source
[NVD] · [CVE record]
EPSS
1.36% · Oct 25, 2026

ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product. This vulnerability is different from CVE-2022-46648.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianruby-gitsid5.6.0-1fixed
Debianruby-gitforky5.6.0-1fixed
Debianruby-gittrixie1.13.1-1fixed
Debianruby-gitbookworm1.13.1-1fixed
Ubunturuby-git16.041.2.8-1vulnerable
Ubunturuby-git18.041.2.8-1vulnerable
Ubunturuby-git20.041.2.8-1vulnerable
Ubunturuby-git20.041.6.0+0-1vulnerable
Ubunturuby-git22.041.7.0-1vulnerable
Ubunturuby-git22.041.9.1-1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianruby-gitsourcesid1.13.1-1not yet assignedNot reportedNot reported
Debianruby-gitsourceforky1.13.1-1not yet assignedNot reportedNot reported
Debianruby-gitsourcetrixie1.13.1-1not yet assignedNot reportedNot reported
Debianruby-gitsourcebookworm1.13.1-1not yet assignedNot reportedNot reported

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [ruby-git]Fixed
    Details (2)
    • 1.13.1-1 · all · bookworm

      Fixed · Fixed: 1.13.1-1

      dsa · ruby-git · debian · bookworm

    • 1.13.1-1 · all · bookworm

      Fixed · Fixed: 1.13.1-1

      dsa · ruby-git · debian · bookworm

Observed:

References