
CVE catalog
CVE-2023-22457
UBUNTU-CVE-2023-22457
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 19.28% · Oct 25, 2026
CKEditor Integration UI adds support for editing wiki pages using CKEditor. Prior to versions 1.64.3,t he `CKEditor.HTMLConverter` document lacked a protection against Cross-Site Request Forgery (CSRF), allowing to execute macros with the rights of the current user. If a privileged user with programming rights was tricked into executing a GET request to this document with certain parameters (e.g., via an image with a corresponding URL embedded in a comment or via a redirect), this would allow arbitrary remote code execution and the attacker could gain rights, access private information or impact the availability of the wiki. The issue has been patched in the CKEditor Integration version 1.64.3. This has also been patched in the version of the CKEditor integration that is bundled starting with XWiki 14.6 RC1. There are no known workarounds for this other than upgrading the CKEditor integration to a fixed version.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | ldap-account-manager | 16.04 | 4.9-1 | vulnerable |
| Ubuntu | ldap-account-manager | 16.04 | 5.1-1 | vulnerable |
| Ubuntu | ldap-account-manager | 16.04 | 5.2-1 | vulnerable |
| Ubuntu | ldap-account-manager | 16.04 | 5.2-1ubuntu1 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.11-2 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.12-3 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.12-4 | vulnerable |
| Ubuntu | request-tracker4 | 16.04 | 4.2.12-5 | vulnerable |
| Ubuntu | ckeditor3 | 18.04 | 3.6.6.1+dfsg-1 | vulnerable |
| Ubuntu | ldap-account-manager | 18.04 | 5.7-1 | vulnerable |
| Ubuntu | ldap-account-manager | 18.04 | 6.1-1 | vulnerable |
| Ubuntu | ldap-account-manager | 18.04 | 6.2-1 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.1-5 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.2-1 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.2-2 | vulnerable |
| Ubuntu | request-tracker4 | pro | 4.4.2-2ubuntu0.1~esm1 | vulnerable |
| Ubuntu | ckeditor3 | 20.04 | 3.6.6.1+dfsg-3 | vulnerable |
| Ubuntu | ckeditor3 | 20.04 | 3.6.6.1+dfsg-4 | vulnerable |
| Ubuntu | ldap-account-manager | 20.04 | 6.7-1 | vulnerable |
| Ubuntu | request-tracker4 | 20.04 | 4.4.3-2 | vulnerable |
| Ubuntu | request-tracker4 | 20.04 | 4.4.3-2+deb10u3build0.20.04.1 | vulnerable |
| Ubuntu | ckeditor3 | 22.04 | 3.6.6.1+dfsg-7 | vulnerable |
| Ubuntu | ldap-account-manager | 22.04 | 7.5-1 | vulnerable |
| Ubuntu | ldap-account-manager | 22.04 | 7.7-1 | vulnerable |
| Ubuntu | request-tracker4 | 22.04 | 4.4.4+dfsg-2ubuntu1 | vulnerable |
| Ubuntu | request-tracker4 | 22.04 | 4.4.4+dfsg-2ubuntu1.22.04.1 | vulnerable |
| Ubuntu | ckeditor3 | 24.04 | 3.6.6.1+dfsg-7 | vulnerable |
| Ubuntu | ldap-account-manager | 24.04 | 8.3-1 | vulnerable |
| Ubuntu | ldap-account-manager | 24.04 | 8.5-1 | vulnerable |
| Ubuntu | request-tracker4 | 24.04 | 4.4.4+dfsg-2ubuntu1 | vulnerable |
| Ubuntu | request-tracker4 | 24.04 | 4.4.4+dfsg-2ubuntu2 | vulnerable |
| Ubuntu | request-tracker4 | 24.04 | 4.4.7+dfsg-1 | vulnerable |
| Ubuntu | ldap-account-manager | 25.10 | 9.0-1 | vulnerable |
| Ubuntu | request-tracker4 | 25.10 | 4.4.7+dfsg-4syncable1 | vulnerable |
| Ubuntu | ldap-account-manager | 26.04 | 9.0-1 | vulnerable |
| Ubuntu | ldap-account-manager | 26.04 | 9.0-1build1 | vulnerable |
| Ubuntu | request-tracker4 | 26.04 | 4.4.7+dfsg-4syncable1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.