CVE catalog

CVE-2023-24809

nethack: CVE-2023-24809

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
0.24% · Oct 25, 2026

NetHack is a single player dungeon exploration game. Starting with version 3.6.2 and prior to version 3.6.7, illegal input to the "C" (call) command can cause a buffer overflow and crash the NetHack process. This vulnerability may be a security issue for systems that have NetHack installed suid/sgid and for shared systems. For all systems, it may result in a process crash. This issue is resolved in NetHack 3.6.7. There are no known workarounds.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannethacksid3.6.7-4fixed
Debiannethackforky3.6.7-4fixed
Debiannethacktrixie3.6.7-1fixed
Debiannethackbookworm3.6.6-3vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannethacksourcesid3.6.7-1not yet assignedNot reported[1031869]
Debiannethacksourceforky3.6.7-1not yet assignedNot reported[1031869]
Debiannethacksourcetrixie3.6.7-1not yet assignedNot reported[1031869]
Debiannethacksourcebookworm(unfixed)not yet assignedNot reported[1031869]

[Debian bug #1031869]

Notes

[bookworm] nethack: Minor issue

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

References