
CVE catalog
CVE-2023-25173
containerd: CVE-2023-25173
- Severity
- High · CVSS 7.3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.54% · Oct 25, 2026
containerd is an open source container runtime. A bug was found in containerd prior to versions 1.6.18 and 1.5.18 where supplementary groups are not set up properly inside a container. If an attacker has direct access to a container and manipulates their supplementary group access, they may be able to use supplementary group access to bypass primary group restrictions in some cases, potentially gaining access to sensitive information or gaining the ability to execute code in that container. Downstream applications that use the containerd client library may be affected as well. This bug has been fixed in containerd v1.6.18 and v.1.5.18. Users should update to these versions and recreate containers to resolve this issue. Users who rely on a downstream application that uses containerd's client library should check that application for a separate advisory and instructions. As a workaround, ensure that the `"USER $USERNAME"` Dockerfile instruction is not used. Instead, set the container entrypoint to a value similar to `ENTRYPOINT ["su", "-", "user"]` to allow `su` to properly set up supplementary groups.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | containerd | sid | 2.1.9+ds1-5 | fixed |
| Debian | containerd | forky | 2.1.9+ds1-5 | fixed |
| Debian | containerd | trixie | 1.7.24~ds1-6+deb13u1 | fixed |
| Debian | containerd | trixie-security | 1.7.24~ds1-6+deb13u1 | fixed |
| Debian | containerd | bookworm | 1.6.20~ds1-1+deb12u3 | fixed |
| Debian | containerd | bookworm-security | 1.6.20~ds1-1+deb12u2 | fixed |
| Ubuntu | containerd | pro | 0.2.5-0ubuntu2 | vulnerable |
| Ubuntu | containerd | pro | 1.2.6-0ubuntu1~18.04.1 | vulnerable |
| Ubuntu | containerd | pro | 1.2.6-0ubuntu1~18.04.2 | vulnerable |
| Ubuntu | containerd | pro | 1.3.3-0ubuntu1~18.04.1 | vulnerable |
| Ubuntu | containerd | pro | 1.3.3-0ubuntu1~18.04.2 | vulnerable |
| Ubuntu | containerd | pro | 1.3.3-0ubuntu1~18.04.3 | vulnerable |
| Ubuntu | containerd | pro | 1.3.3-0ubuntu1~18.04.4 | vulnerable |
| Ubuntu | containerd | pro | 1.4.4-0ubuntu1~18.04.2 | vulnerable |
| Ubuntu | containerd | pro | 1.5.2-0ubuntu1~18.04.1 | vulnerable |
| Ubuntu | containerd | pro | 1.5.2-0ubuntu1~18.04.2 | vulnerable |
| Ubuntu | containerd | pro | 1.5.2-0ubuntu1~18.04.3 | vulnerable |
| Ubuntu | containerd | pro | 1.5.5-0ubuntu3~18.04.1 | vulnerable |
| Ubuntu | containerd | pro | 1.5.5-0ubuntu3~18.04.2 | vulnerable |
| Ubuntu | containerd | pro | 1.5.9-0ubuntu1~18.04.1 | vulnerable |
| Ubuntu | containerd | pro | 1.5.9-0ubuntu1~18.04.2 | vulnerable |
| Ubuntu | containerd | pro | 1.6.12-0ubuntu1~18.04.1 | vulnerable |
| Ubuntu | containerd | pro | 1.6.12-0ubuntu1~18.04.1+esm1 | fixed |
| Ubuntu | containerd | 20.04 | 1.2.10-0ubuntu1 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.3.2-0ubuntu1 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.3.3-0ubuntu1 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.3.3-0ubuntu2 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.3.3-0ubuntu2.1 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.3.3-0ubuntu2.2 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.3.3-0ubuntu2.3 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.4.4-0ubuntu1~20.04.2 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.5.2-0ubuntu1~20.04.1 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.5.2-0ubuntu1~20.04.2 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.5.2-0ubuntu1~20.04.3 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.5.5-0ubuntu3~20.04.1 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.5.5-0ubuntu3~20.04.2 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.5.9-0ubuntu1~20.04.1 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.5.9-0ubuntu1~20.04.4 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.5.9-0ubuntu1~20.04.5 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.5.9-0ubuntu1~20.04.6 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.6.12-0ubuntu1~20.04.1 | vulnerable |
| Ubuntu | containerd | 20.04 | 1.6.12-0ubuntu1~20.04.3 | fixed |
| Ubuntu | containerd | 22.04 | 1.5.5-0ubuntu3 | vulnerable |
| Ubuntu | containerd | 22.04 | 1.5.9-0ubuntu1 | vulnerable |
| Ubuntu | containerd | 22.04 | 1.5.9-0ubuntu2 | vulnerable |
| Ubuntu | containerd | 22.04 | 1.5.9-0ubuntu3 | vulnerable |
| Ubuntu | containerd | 22.04 | 1.5.9-0ubuntu3.1 | vulnerable |
| Ubuntu | containerd | 22.04 | 1.6.12-0ubuntu1~22.04.1 | vulnerable |
| Ubuntu | containerd | 22.04 | 1.6.12-0ubuntu1~22.04.3 | fixed |
| Opensuse | helm | tumbleweed | 3.13.0-2.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | containerd | source | sid | 1.6.18~ds1-1 | not yet assigned | Not reported | Not reported |
| Debian | containerd | source | forky | 1.6.18~ds1-1 | not yet assigned | Not reported | Not reported |
| Debian | containerd | source | trixie | 1.6.18~ds1-1 | not yet assigned | Not reported | Not reported |
| Debian | containerd | source | bookworm | 1.6.18~ds1-1 | not yet assigned | Not reported | Not reported |
| Ubuntu | containerd | deb | pro | 1.6.12-0ubuntu1~18.04.1+esm1 | Not reported | UBUNTU-CVE-2023-25173 | Not reported |
| Ubuntu | containerd | deb | 20.04 | 1.6.12-0ubuntu1~20.04.3 | Not reported | UBUNTU-CVE-2023-25173 | Not reported |
| Ubuntu | containerd | deb | 22.04 | 1.6.12-0ubuntu1~22.04.3 | Not reported | UBUNTU-CVE-2023-25173 | Not reported |
| Opensuse | helm | rpm | tumbleweed | 3.13.0-2.1 | Not reported | OPENSUSE-SU-2024:13295-1 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2023_1826-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2023-25173]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2023-25173]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:13295-1]
- [https://security-tracker.debian.org/tracker/CVE-2023-25173]
- [https://security.access.redhat.com/data/csaf/v2/vex/2023/cve-2023-25173.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-3146.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]