
CVE catalog
CVE-2023-25564
gss-ntlmssp affected and fixed versions
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, memory corruption can be triggered when decoding UTF16 strings. The variable `outlen` was not initialized and could cause writing a zero to an arbitrary place in memory if `ntlm_str_convert()` were to fail, which would leave `outlen` uninitialized. This can lead to a denial of service if the write hits unmapped memory or randomly corrupts a byte in the application memory space. This vulnerability can trigger an out-of-bounds write, leading to memory corruption. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This issue is fixed in version 1.2.0.
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.94% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [
{
"name": "gss-ntlmssp",
"status": "fixed",
"release": "sid",
"version": "1.3.1-1"
},
{
"name": "gss-ntlmssp",
"status": "fixed",
"release": "forky",
"version": "1.3.1-1"
},
{
"name": "gss-ntlmssp",
"status": "fixed",
"release": "trixie",
"version": "1.2.0-1"
},
{
"name": "gss-ntlmssp",
"status": "fixed",
"release": "bookworm",
"version": "1.2.0-1"
}
],
"fixed_versions": [
{
"bug": 1031369,
"name": "gss-ntlmssp",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "1.2.0-1"
},
{
"bug": 1031369,
"name": "gss-ntlmssp",
"type": "source",
"origin": null,
"release": "forky",
"urgency": "not yet assigned",
"fixed_version": "1.2.0-1"
},
{
"bug": 1031369,
"name": "gss-ntlmssp",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "not yet assigned",
"fixed_version": "1.2.0-1"
},
{
"bug": 1031369,
"name": "gss-ntlmssp",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": "1.2.0-1"
}
],
"distribution_packages": [
{
"name": "gss-ntlmssp",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.7.0-4ubuntu0.22.04.1~esm1"
}
]
}
],
"release": "pro",
"versions": [
"0.7.0-4build3",
"0.7.0-4build4"
],
"ecosystem": "deb",
"fixed_version": "0.7.0-4ubuntu0.22.04.1~esm1",
"provider_record_id": "UBUNTU-CVE-2023-25564"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [gss-ntlmssp]Unknown
Details (2)
1.2.0-1· amd64 · bookwormFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · bookworm; dsa · gss-ntlmssp · debian · 12
1.2.0-1· arm64 · bookwormFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · bookworm; dsa · gss-ntlmssp · debian · 12
- [gss-ntlmssp-dev]Unknown
Source package: [gss-ntlmssp]
Details (2)
1.2.0-1· amd64 · bookwormFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · bookworm; dsa · gss-ntlmssp · debian · 12
1.2.0-1· arm64 · bookwormFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · bookworm; dsa · gss-ntlmssp · debian · 12
[Debian 13 (Trixie)]
- [gss-ntlmssp]Unknown
Source package: [gss-ntlmssp]
Details (2)
1.2.0-1+b2· amd64 · trixieFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · 13
1.2.0-1+b3· arm64 · trixieFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · 13
- [gss-ntlmssp-dev]Unknown
Source package: [gss-ntlmssp]
Details (2)
1.2.0-1+b2· amd64 · trixieFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · 13
1.2.0-1+b3· arm64 · trixieFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2023_3097.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2023-25564]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2023-25564]
- [https://security-tracker.debian.org/tracker/CVE-2023-25564]
- [https://security.access.redhat.com/data/csaf/v2/vex/2023/cve-2023-25564.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-1238.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]