CVE catalog

CVE-2023-25565

gss-ntlmssp: CVE-2023-25565

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
1.10% · Oct 25, 2026

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, an incorrect free when decoding target information can trigger a denial of service. The error condition incorrectly assumes the `cb` and `sh` buffers contain a copy of the data that needs to be freed. However, that is not the case. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This will likely trigger an assertion failure in `free`, causing a denial-of-service. This issue is fixed in version 1.2.0.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiangss-ntlmsspsid1.3.1-1fixed
Debiangss-ntlmsspforky1.3.1-1fixed
Debiangss-ntlmssptrixie1.2.0-1fixed
Debiangss-ntlmsspbookworm1.2.0-1fixed
Ubuntugss-ntlmssppro0.7.0-4build3vulnerable
Ubuntugss-ntlmssppro0.7.0-4build4vulnerable
Ubuntugss-ntlmssppro0.7.0-4ubuntu0.22.04.1~esm1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiangss-ntlmsspsourcesid1.2.0-1not yet assignedNot reported[1031369]
Debiangss-ntlmsspsourceforky1.2.0-1not yet assignedNot reported[1031369]
Debiangss-ntlmsspsourcetrixie1.2.0-1not yet assignedNot reported[1031369]
Debiangss-ntlmsspsourcebookworm1.2.0-1not yet assignedNot reported[1031369]
Ubuntugss-ntlmsspdebpro0.7.0-4ubuntu0.22.04.1~esm1Not reportedUBUNTU-CVE-2023-25565Not reported

[Debian bug #1031369]

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

References