
CVE catalog
CVE-2023-25566
gss-ntlmssp: CVE-2023-25566
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.10% · Oct 27, 2026
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, a memory leak can be triggered when parsing usernames which can trigger a denial-of-service. The domain portion of a username may be overridden causing an allocated memory area the size of the domain name to be leaked. An attacker can leak memory via the main `gss_accept_sec_context` entry point, potentially causing a denial-of-service. This issue is fixed in version 1.2.0.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | gss-ntlmssp | sid | 1.3.1-1 | fixed |
| Debian | gss-ntlmssp | forky | 1.3.1-1 | fixed |
| Debian | gss-ntlmssp | trixie | 1.2.0-1 | fixed |
| Debian | gss-ntlmssp | bookworm | 1.2.0-1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | gss-ntlmssp | source | sid | 1.2.0-1 | not yet assigned | Not reported | [1031369] |
| Debian | gss-ntlmssp | source | forky | 1.2.0-1 | not yet assigned | Not reported | [1031369] |
| Debian | gss-ntlmssp | source | trixie | 1.2.0-1 | not yet assigned | Not reported | [1031369] |
| Debian | gss-ntlmssp | source | bookworm | 1.2.0-1 | not yet assigned | Not reported | [1031369] |
OpenFactory catalog packages
[Debian 12 (Bookworm)]
- [gss-ntlmssp]Fixed
Details (2)
1.2.0-1· amd64 · bookwormFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · bookworm; dsa · gss-ntlmssp · debian · 12
1.2.0-1· arm64 · bookwormFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · bookworm; dsa · gss-ntlmssp · debian · 12
- [gss-ntlmssp-dev]Fixed
Source package: [gss-ntlmssp]
Details (2)
1.2.0-1· amd64 · bookwormFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · bookworm; dsa · gss-ntlmssp · debian · 12
1.2.0-1· arm64 · bookwormFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · bookworm; dsa · gss-ntlmssp · debian · 12
[Debian 13 (Trixie)]
- [gss-ntlmssp]Fixed
Source package: [gss-ntlmssp]
Details (2)
1.2.0-1+b2· amd64 · trixieFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · 13
1.2.0-1+b3· arm64 · trixieFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · 13
- [gss-ntlmssp-dev]Fixed
Source package: [gss-ntlmssp]
Details (2)
1.2.0-1+b2· amd64 · trixieFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · 13
1.2.0-1+b3· arm64 · trixieFixed · Fixed:
1.2.0-1dsa · gss-ntlmssp · debian · 13
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2023_3097.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2023-25566]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2023-25566]
- [https://security-tracker.debian.org/tracker/CVE-2023-25566]
- [https://security.access.redhat.com/data/csaf/v2/vex/2023/cve-2023-25566.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-1238.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]