CVE catalog

CVE-2023-26053

gradle: CVE-2023-26053

[CVE catalog]

Severity
Low
Source
[NVD] · [CVE record]
EPSS
0.99% · Oct 25, 2026

Gradle is a build tool with a focus on build automation and support for multi-language development. This is a collision attack on long IDs (64bits) for PGP keys. Users of dependency verification in Gradle are vulnerable if they use long IDs for PGP keys in a `trusted-key` or `pgp` element in their dependency verification metadata file. The fix is to fail dependency verification if anything but a fingerprint is used in a trust element in dependency verification metadata. The problem is fixed in Gradle 8.0 and above. The problem is also patched in Gradle 6.9.4 and 7.6.1. As a workaround, use only full fingerprint IDs for `trusted-key` or `pgp` element in the metadata is a protection against this issue.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiangradlesid4.7-1not affected
Debiangradleforky4.6-3not affected
Debiangradletrixie4.4.1-22not affected
Debiangradlebookworm4.4.1-18not affected

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
DebiangradlesourcesidNot affectedunimportantNot reportedNot reported
DebiangradlesourceforkyNot affectedunimportantNot reportedNot reported
DebiangradlesourcetrixieNot affectedunimportantNot reportedNot reported
DebiangradlesourcebookwormNot affectedunimportantNot reportedNot reported

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

References