CVE catalog

CVE-2023-26144

node-graphql: CVE-2023-26144

[CVE catalog]

Severity
Medium · CVSS 5.3CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Published
Source
[NVD] · [CVE record]
EPSS
1.45% · Oct 27, 2026

Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. **Note:** It was not proven that this vulnerability can crash the process.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-graphqlsid16.8.1-7fixed
Debiannode-graphqlforky16.8.1-7fixed
Debiannode-graphqltrixie16.8.1-2fixed
Debiannode-graphqlbookworm16.6.0-2vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-graphqlsourcesid16.8.1-1not yet assignedNot reportedNot reported
Debiannode-graphqlsourceforky16.8.1-1not yet assignedNot reportedNot reported
Debiannode-graphqlsourcetrixie16.8.1-1not yet assignedNot reportedNot reported
Debiannode-graphqlsourcebookworm(unfixed)not yet assignedNot reportedNot reported

Notes

[bookworm] node-graphql: Minor issue

OpenFactory catalog packages

[Debian 12 (Bookworm)]

  • [node-graphql]Affected
    Details (2)
    • 16.6.0-2 · all · bookworm

      Affected

      dsa · node-graphql · debian · bookworm; dsa · node-graphql · debian · 12

    • 16.6.0-2 · all · bookworm

      Affected

      dsa · node-graphql · debian · bookworm; dsa · node-graphql · debian · 12

[Debian 13 (Trixie)]

  • Details (2)
    • 16.8.1-2 · all · trixie

      Fixed · Fixed: 16.8.1-1

      dsa · node-graphql · debian · 13

    • 16.8.1-2 · all · trixie

      Fixed · Fixed: 16.8.1-1

      dsa · node-graphql · debian · 13

Observed:

References