
CVE catalog
CVE-2023-27597
UBUNTU-CVE-2023-27597
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.74% · Oct 25, 2026
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | opensips | 18.04 | 2.2.2-3build2 | vulnerable |
| Ubuntu | opensips | 18.04 | 2.2.2-3build3 | vulnerable |
| Ubuntu | opensips | 18.04 | 2.2.2-3build4 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.