
CVE catalog
CVE-2023-32323
UBUNTU-CVE-2023-32323
- Severity
- Unknown
- Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.98% · Oct 25, 2026
Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. A malicious user on a Synapse homeserver X with permission to create certain state events can disable outbound federation from X to an arbitrary homeserver Y. Synapse instances with federation disabled are not affected. In versions of Synapse up to and including 1.73, Synapse did not limit the size of `invite_room_state`, meaning that it was possible to create an arbitrarily large invite event. Synapse 1.74 refuses to create oversized `invite_room_state` fields. Server operators should upgrade to Synapse 1.74 or newer urgently.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Ubuntu | matrix-synapse | pro | 0.19.2+dfsg-6 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 0.24.0+dfsg-1ubuntu0.1~esm4 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.3.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.4.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.5.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.5.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.6.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.6.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.2-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.7.3-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.8.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.9.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.9.1-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.10.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.10.0-2 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.11.0-1 | vulnerable |
| Ubuntu | matrix-synapse | pro | 1.11.0-1ubuntu0.1~esm2 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.39.0-1 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.47.0-2 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.47.1-1 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.48.0-1 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.49.0-1 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.49.2-1 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.50.1-1 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.50.2-1 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.51.0-1 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.52.0-1 | vulnerable |
| Ubuntu | matrix-synapse | 22.04 | 1.53.0-1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.