
CVE catalog
CVE-2023-36478
jetty9: CVE-2023-36478
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 4.83% · Oct 25, 2026
Eclipse Jetty provides a web server and servlet container. In versions 11.0.0 through 11.0.15, 10.0.0 through 10.0.15, and 9.0.0 through 9.4.52, an integer overflow in `MetaDataBuilder.checkSize` allows for HTTP/2 HPACK header values to exceed their size limit. `MetaDataBuilder.java` determines if a header name or value exceeds the size limit, and throws an exception if the limit is exceeded. However, when length is very large and huffman is true, the multiplication by 4 in line 295 will overflow, and length will become negative. `(_size+length)` will now be negative, and the check on line 296 will not be triggered. Furthermore, `MetaDataBuilder.checkSize` allows for user-entered HPACK header value sizes to be negative, potentially leading to a very large buffer allocation later on when the user-entered size is multiplied by 2. This means that if a user provides a negative length value (or, more precisely, a length value which, when multiplied by the 4/3 fudge factor, is negative), and this length value is a very large positive number when multiplied by 2, then the user can cause a very large buffer to be allocated on the server. Users of HTTP/2 can be impacted by a remote denial of service attack. The issue has been fixed in versions 11.0.16, 10.0.16, and 9.4.53. There are no known workarounds.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | jetty9 | sid | 9.4.58-2 | fixed |
| Debian | jetty9 | forky | 9.4.58-2 | fixed |
| Debian | jetty9 | trixie | 9.4.57-1.1~deb13u1 | fixed |
| Debian | jetty9 | trixie-security | 9.4.57-1.1~deb13u1 | fixed |
| Debian | jetty9 | bookworm | 9.4.57-1.1~deb12u1 | fixed |
| Debian | jetty9 | bookworm-security | 9.4.57-1.1~deb12u1 | fixed |
| Suse | jetty-minimal | linux enterprise module for development tools 15 sp4 | 9.4.53-150200.3.22.1 | fixed |
| Suse | jetty-minimal | linux enterprise module for development tools 15 sp5 | 9.4.53-150200.3.22.1 | fixed |
| Suse | jetty-minimal | linux enterprise high performance computing 15 sp2-ltss | 9.4.53-150200.3.22.1 | fixed |
| Suse | jetty-minimal | linux enterprise high performance computing 15 sp3-espos | 9.4.53-150200.3.22.1 | fixed |
| Suse | jetty-minimal | linux enterprise high performance computing 15 sp3-ltss | 9.4.53-150200.3.22.1 | fixed |
| Suse | jetty-minimal | linux enterprise server 15 sp2-ltss | 9.4.53-150200.3.22.1 | fixed |
| Suse | jetty-minimal | linux enterprise server 15 sp3-ltss | 9.4.53-150200.3.22.1 | fixed |
| Suse | jetty-minimal | linux enterprise server for sap applications 15 sp2 | 9.4.53-150200.3.22.1 | fixed |
| Suse | jetty-minimal | linux enterprise server for sap applications 15 sp3 | 9.4.53-150200.3.22.1 | fixed |
| Suse | jetty-minimal | enterprise storage 7.1 | 9.4.53-150200.3.22.1 | fixed |
| Opensuse | jetty-minimal | leap 15.4 | 9.4.53-150200.3.22.1 | fixed |
| Opensuse | jetty-minimal | leap 15.5 | 9.4.53-150200.3.22.1 | fixed |
| Ubuntu | jetty | 14.04 | 6.1.26-1ubuntu1 | vulnerable |
| Ubuntu | jetty | 14.04 | 6.1.26-1ubuntu1.1 | vulnerable |
| Ubuntu | jetty | 14.04 | 6.1.26-1ubuntu1.2 | vulnerable |
| Ubuntu | jetty | 16.04 | 6.1.26-5 | vulnerable |
| Ubuntu | jetty | 16.04 | 6.1.26-5ubuntu0.1 | vulnerable |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | jetty9 | source | sid | 9.4.53-1 | not yet assigned | Not reported | Not reported |
| Debian | jetty9 | source | forky | 9.4.53-1 | not yet assigned | Not reported | Not reported |
| Debian | jetty9 | source | trixie | 9.4.53-1 | not yet assigned | Not reported | Not reported |
| Debian | jetty9 | source | bookworm | 9.4.50-4+deb12u2 | not yet assigned | Not reported | Not reported |
| Suse | jetty-minimal | rpm | linux enterprise module for development tools 15 sp4 | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Suse | jetty-minimal | rpm | linux enterprise module for development tools 15 sp5 | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Suse | jetty-minimal | rpm | linux enterprise high performance computing 15 sp2-ltss | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Suse | jetty-minimal | rpm | linux enterprise high performance computing 15 sp3-espos | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Suse | jetty-minimal | rpm | linux enterprise high performance computing 15 sp3-ltss | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Suse | jetty-minimal | rpm | linux enterprise server 15 sp2-ltss | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Suse | jetty-minimal | rpm | linux enterprise server 15 sp3-ltss | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Suse | jetty-minimal | rpm | linux enterprise server for sap applications 15 sp2 | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Suse | jetty-minimal | rpm | linux enterprise server for sap applications 15 sp3 | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Suse | jetty-minimal | rpm | enterprise storage 7.1 | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Opensuse | jetty-minimal | rpm | leap 15.4 | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
| Opensuse | jetty-minimal | rpm | leap 15.5 | 9.4.53-150200.3.22.1 | Not reported | SUSE-SU-2023:4210-1 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2023_4210-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2023-36478]
- [https://osv.dev/vulnerability/DSA-5540-1]
- [https://osv.dev/vulnerability/SUSE-SU-2023:4210-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2023-36478]
- [https://security-tracker.debian.org/tracker/CVE-2023-36478]
- [https://security.access.redhat.com/data/csaf/v2/vex/2023/cve-2023-36478.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2024/wid-sec-w-2024-1637.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]