CVE catalog

CVE-2023-39456

trafficserver: CVE-2023-39456

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
58.29% · Oct 25, 2026

Improper Input Validation vulnerability in Apache Traffic Server with malformed HTTP/2 frames.This issue affects Apache Traffic Server: from 9.0.0 through 9.2.2. Users are recommended to upgrade to version 9.2.3, which fixes the issue.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiantrafficserverbookworm9.2.5+ds-0+deb12u4fixed
Debiantrafficserverbookworm-security9.2.5+ds-0+deb12u4fixed
Ubuntutrafficserverpro8.1.1+ds-1.1vulnerable
Ubuntutrafficserverpro9.1.1+ds-2build1vulnerable
Ubuntutrafficserverpro9.1.1+ds-2ubuntu0.1~esm1vulnerable
Ubuntutrafficserverpro9.1.1+ds-2ubuntu0.1vulnerable
Ubuntutrafficserverpro9.1.1+ds-2ubuntu0.1+esm1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiantrafficserversourcebookworm9.2.3+ds-1+deb12u1not yet assignedNot reported[1054427]

[Debian bug #1054427]

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

References