CVE catalog

CVE-2023-40032

vips: CVE-2023-40032

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
0.25% · Oct 25, 2026

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianvipssid8.18.7-1fixed
Debianvipsforky8.18.7-1fixed
Debianvipstrixie8.16.1-1+deb13u1fixed
Debianvipstrixie-security8.16.1-1+deb13u2fixed
Debianvipsbookworm8.14.1-3+deb12u3fixed
Debianvipsbookworm-security8.14.1-3+deb12u2fixed
Ubuntuvipspro8.10.5-2ubuntu1vulnerable
Ubuntuvipspro8.11.4-2vulnerable
Ubuntuvipspro8.12.1-1vulnerable
Ubuntuvipspro8.12.1-1build1vulnerable
Ubuntuvipspro8.12.1-1ubuntu0.1~esm1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianvipssourcesid8.14.4-1not yet assignedNot reportedNot reported
Debianvipssourceforky8.14.4-1not yet assignedNot reportedNot reported
Debianvipssourcetrixie8.14.4-1not yet assignedNot reportedNot reported
Debianvipssourcebookworm8.14.1-3+deb12u1not yet assignedNot reportedNot reported
Ubuntuvipsdebpro8.12.1-1ubuntu0.1~esm1Not reportedUBUNTU-CVE-2023-40032Not reported

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

References