
CVE catalog
CVE-2023-41081
libapache-mod-jk: CVE-2023-41081
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 1.59% · Oct 25, 2026
Important: Authentication Bypass CVE-2023-41081 The mod_jk component of Apache Tomcat Connectors in some circumstances, such as when a configuration included "JkOptions +ForwardDirectories" but the configuration did not provide explicit mounts for all possible proxied requests, mod_jk would use an implicit mapping and map the request to the first defined worker. Such an implicit mapping could result in the unintended exposure of the status worker and/or bypass security constraints configured in httpd. As of JK 1.2.49, the implicit mapping functionality has been removed and all mappings must now be via explicit configuration. Only mod_jk is affected by this issue. The ISAPI redirector is not affected. This issue affects Apache Tomcat Connectors (mod_jk only): from 1.2.0 through 1.2.48. Users are recommended to upgrade to version 1.2.49, which fixes the issue. History 2023-09-13 Original advisory 2023-09-28 Updated summary
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | libapache-mod-jk | sid | 1:1.2.50-1 | fixed |
| Debian | libapache-mod-jk | forky | 1:1.2.50-1 | fixed |
| Debian | libapache-mod-jk | trixie | 1:1.2.50-1 | fixed |
| Debian | libapache-mod-jk | bookworm | 1:1.2.48-2+deb12u2 | fixed |
| Ubuntu | libapache-mod-jk | pro | 1:1.2.40+svn150520-1 | vulnerable |
| Ubuntu | libapache-mod-jk | pro | 1:1.2.41-1 | vulnerable |
| Ubuntu | libapache-mod-jk | pro | 1:1.2.41-1ubuntu0.1~esm1 | vulnerable |
| Ubuntu | libapache-mod-jk | pro | 1:1.2.41-1ubuntu0.1~esm2 | fixed |
| Ubuntu | libapache-mod-jk | pro | 1:1.2.42-1 | vulnerable |
| Ubuntu | libapache-mod-jk | pro | 1:1.2.43-1 | vulnerable |
| Ubuntu | libapache-mod-jk | pro | 1:1.2.43-1ubuntu0.1~esm1 | fixed |
| Ubuntu | libapache-mod-jk | 20.04 | 1:1.2.46-1 | vulnerable |
| Ubuntu | libapache-mod-jk | 20.04 | 1:1.2.46-1ubuntu0.1 | fixed |
| Ubuntu | libapache-mod-jk | 22.04 | 1:1.2.48-1 | vulnerable |
| Ubuntu | libapache-mod-jk | 22.04 | 1:1.2.48-1ubuntu0.1 | fixed |
| Ubuntu | libapache-mod-jk | pro | 1:1.2.42-1 | vulnerable |
| Ubuntu | libapache-mod-jk | pro | 1:1.2.43-1 | vulnerable |
| Ubuntu | libapache-mod-jk | pro | 1:1.2.43-1ubuntu0.1~esm1 | fixed |
| Ubuntu | libapache-mod-jk | 20.04 | 1:1.2.46-1 | vulnerable |
| Ubuntu | libapache-mod-jk | 20.04 | 1:1.2.46-1ubuntu0.1 | fixed |
| Ubuntu | libapache-mod-jk | 22.04 | 1:1.2.48-1 | vulnerable |
| Ubuntu | libapache-mod-jk | 22.04 | 1:1.2.48-1ubuntu0.1 | fixed |
| Suse | apache2-mod_jk | linux enterprise module for server applications 15 sp6 | 1.2.50-150100.6.12.1 | fixed |
| Opensuse | apache2-mod_jk | leap 15.6 | 1.2.50-150100.6.12.1 | fixed |
| Suse | apache2-mod_jk | linux enterprise server 12 sp5 | 1.2.49-7.9.1 | fixed |
| Suse | apache2-mod_jk | linux enterprise server for sap applications 12 sp5 | 1.2.49-7.9.1 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | libapache-mod-jk | source | sid | 1:1.2.49-1 | not yet assigned | Not reported | [1051956] |
| Debian | libapache-mod-jk | source | forky | 1:1.2.49-1 | not yet assigned | Not reported | [1051956] |
| Debian | libapache-mod-jk | source | trixie | 1:1.2.49-1 | not yet assigned | Not reported | [1051956] |
| Debian | libapache-mod-jk | source | bookworm | 1:1.2.48-2+deb12u1 | not yet assigned | Not reported | [1051956] |
| Ubuntu | libapache-mod-jk | deb | pro | 1:1.2.41-1ubuntu0.1~esm2 | Not reported | USN-8369-2 | Not reported |
| Ubuntu | libapache-mod-jk | deb | pro | 1:1.2.43-1ubuntu0.1~esm1 | Not reported | USN-6826-1 | Not reported |
| Ubuntu | libapache-mod-jk | deb | 20.04 | 1:1.2.46-1ubuntu0.1 | Not reported | USN-6826-1 | Not reported |
| Ubuntu | libapache-mod-jk | deb | 22.04 | 1:1.2.48-1ubuntu0.1 | Not reported | USN-6826-1 | Not reported |
| Ubuntu | libapache-mod-jk | deb | pro | 1:1.2.43-1ubuntu0.1~esm1 | Not reported | UBUNTU-CVE-2023-41081 | Not reported |
| Ubuntu | libapache-mod-jk | deb | 20.04 | 1:1.2.46-1ubuntu0.1 | Not reported | UBUNTU-CVE-2023-41081 | Not reported |
| Ubuntu | libapache-mod-jk | deb | 22.04 | 1:1.2.48-1ubuntu0.1 | Not reported | UBUNTU-CVE-2023-41081 | Not reported |
| Suse | apache2-mod_jk | rpm | linux enterprise module for server applications 15 sp6 | 1.2.50-150100.6.12.1 | Not reported | SUSE-SU-2025:0102-1 | Not reported |
| Opensuse | apache2-mod_jk | rpm | leap 15.6 | 1.2.50-150100.6.12.1 | Not reported | SUSE-SU-2025:0102-1 | Not reported |
| Suse | apache2-mod_jk | rpm | linux enterprise server 12 sp5 | 1.2.49-7.9.1 | Not reported | SUSE-SU-2024:1198-1 | Not reported |
| Suse | apache2-mod_jk | rpm | linux enterprise server for sap applications 12 sp5 | 1.2.49-7.9.1 | Not reported | SUSE-SU-2024:1198-1 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
References
- [https://ftp.suse.com/pub/projects/security/csaf/suse-su-2024_1198-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2023-41081]
- [https://osv.dev/vulnerability/DLA-3580-1]
- [https://osv.dev/vulnerability/SUSE-SU-2024:1198-1]
- [https://osv.dev/vulnerability/SUSE-SU-2025:0102-1]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2023-41081]
- [https://osv.dev/vulnerability/USN-6826-1]
- [https://osv.dev/vulnerability/USN-8369-2]
- [https://security-tracker.debian.org/tracker/CVE-2023-41081]
- [https://security.access.redhat.com/data/csaf/v2/vex/2023/cve-2023-41081.json]
- [https://wid.cert-bund.de/.well-known/csaf/white/2023/wid-sec-w-2023-2917.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]