CVE catalog

CVE-2023-43643

libowasp-antisamy-java: CVE-2023-43643

[CVE catalog]

Severity
Medium
Published
Source
[NVD] · [CVE record]
EPSS
0.54% · Oct 25, 2026

AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to version 1.7.4, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This issue has been patched in AntiSamy 1.7.4 and later.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibowasp-antisamy-javasid1.7.8-1fixed
Debianlibowasp-antisamy-javaforky1.7.4-1fixed
Debianlibowasp-antisamy-javatrixie1.7.4-1fixed
Debianlibowasp-antisamy-javabookworm1.5.3+dfsg-1.1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianlibowasp-antisamy-javasourcesid1.7.4-1not yet assignedNot reported[1054164]
Debianlibowasp-antisamy-javasourceforky1.7.4-1not yet assignedNot reported[1054164]
Debianlibowasp-antisamy-javasourcetrixie1.7.4-1not yet assignedNot reported[1054164]
Debianlibowasp-antisamy-javasourcebookworm(unfixed)not yet assignedNot reported[1054164]

[Debian bug #1054164]

Notes

[bookworm] libowasp-antisamy-java: Minor issue

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

References