CVE catalog

CVE-2023-49295

golang-github-lucas-clemente-quic-go: CVE-2023-49295

[CVE catalog]

Severity
Medium · CVSS 6.5CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
1.20% · Oct 25, 2026

quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiangolang-github-lucas-clemente-quic-gosid0.59.0-2fixed
Debiangolang-github-lucas-clemente-quic-goforky0.59.0-2fixed
Debiangolang-github-lucas-clemente-quic-gotrixie0.50.1-2fixed
Debiangolang-github-lucas-clemente-quic-gobookworm0.29.0-1vulnerable
Opensusednscrypt-proxyleap 16.02.1.16-bp160.1.1fixed
Opensusekubotumbleweed0.32.1-1.1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiangolang-github-lucas-clemente-quic-gosourcesid0.38.2-1not yet assignedNot reportedNot reported
Debiangolang-github-lucas-clemente-quic-gosourceforky0.38.2-1not yet assignedNot reportedNot reported
Debiangolang-github-lucas-clemente-quic-gosourcetrixie0.38.2-1not yet assignedNot reportedNot reported
Debiangolang-github-lucas-clemente-quic-gosourcebookworm(unfixed)not yet assignedNot reportedNot reported
Opensusednscrypt-proxyrpmleap 16.02.1.16-bp160.1.1Not reportedOPENSUSE-RU-2026:21160-1Not reported
Opensusekuborpmtumbleweed0.32.1-1.1Not reportedOPENSUSE-SU-2025:14626-1Not reported

Notes

[bookworm] golang-github-lucas-clemente-quic-go: Minor issue

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

References