
CVE catalog
CVE-2024-13903
DEBIAN-CVE-2024-13903
- Severity
- High · CVSS 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Published
- Updated
- Source
- [NVD] · [CVE record]
- EPSS
- 0.72% · Oct 25, 2026
A vulnerability was found in quickjs-ng QuickJS up to 0.8.0. It has been declared as problematic. Affected by this vulnerability is the function JS_GetRuntime of the file quickjs.c of the component qjs. The manipulation leads to stack-based buffer overflow. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The patch is named 99c02eb45170775a9a679c32b45dd4000ea67aff. It is recommended to upgrade the affected component.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | quickjs | 13 | 2025.04.26-1 | vulnerable |
| Debian | quickjs | 14 | 2025.04.26-1 | vulnerable |
Fixed-version evidence
OpenFactory catalog packages
[Debian 13 (Trixie)]
- [libquickjs]Affected
Source package: [quickjs]
Details (2)
2025.04.26-1· amd64 · trixieAffected
pypi · quickjs · debian · 13
2025.04.26-1· arm64 · trixieAffected
pypi · quickjs · debian · 13
- [quickjs]Affected
Details (2)
2025.04.26-1· amd64 · trixieAffected
pypi · quickjs · debian · 13
2025.04.26-1· arm64 · trixieAffected
pypi · quickjs · debian · 13
Observed: