CVE catalog

CVE-2024-21535

DEBIAN-CVE-2024-21535

[CVE catalog]

Severity
Medium · CVSS 6.1CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Published
Updated
Source
[NVD] · [CVE record]
EPSS
0.52% · Oct 25, 2026

Versions of the package markdown-to-jsx before 7.4.0 are vulnerable to Cross-site Scripting (XSS) via the src property due to improper input sanitization. An attacker can execute arbitrary code by injecting a malicious iframe element in the markdown.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debiannode-markdown-to-jsx137.2.0+dfsg-3fixed
Debiannode-markdown-to-jsx147.2.0+dfsg-3fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debiannode-markdown-to-jsxdeb137.2.0+dfsg-3Not reportedDEBIAN-CVE-2024-21535Not reported
Debiannode-markdown-to-jsxdeb147.2.0+dfsg-3Not reportedDEBIAN-CVE-2024-21535Not reported

OpenFactory catalog packages

[Debian 13 (Trixie)]

  • Details (2)
    • 7.2.0+dfsg-3 · all · trixie

      Fixed · Fixed: 7.2.0+dfsg-3

      pypi · node-markdown-to-jsx · debian · 13

    • 7.2.0+dfsg-3 · all · trixie

      Fixed · Fixed: 7.2.0+dfsg-3

      pypi · node-markdown-to-jsx · debian · 13

Observed:

References