
CVE catalog
CVE-2024-23525
libspreadsheet-parsexlsx-perl affected and fixed versions
The Spreadsheet::ParseXLSX package before 0.30 for Perl allows XXE attacks because it neglects to use the no_xxe option of XML::Twig.
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 0.78% · Oct 27, 2026
Projects and upstream resources
Reported versions and fixes
Each observation applies to its named package, distribution, and release. Distribution backports can fix a vulnerability while retaining an older upstream version number.
Version impact has not been established. The original provider fields are retained below.
Provider details and historical evidence
Original provider fields
{
"package_releases": [
{
"name": "libspreadsheet-parsexlsx-perl",
"status": "fixed",
"release": "sid",
"version": "0.37-1"
},
{
"name": "libspreadsheet-parsexlsx-perl",
"status": "fixed",
"release": "forky",
"version": "0.37-1"
},
{
"name": "libspreadsheet-parsexlsx-perl",
"status": "fixed",
"release": "trixie",
"version": "0.36-1"
},
{
"name": "libspreadsheet-parsexlsx-perl",
"status": "fixed",
"release": "bookworm",
"version": "0.27-3+deb12u2"
}
],
"fixed_versions": [
{
"bug": 1061098,
"name": "libspreadsheet-parsexlsx-perl",
"type": "source",
"origin": null,
"release": "sid",
"urgency": "not yet assigned",
"fixed_version": "0.31-1"
},
{
"bug": 1061098,
"name": "libspreadsheet-parsexlsx-perl",
"type": "source",
"origin": null,
"release": "forky",
"urgency": "not yet assigned",
"fixed_version": "0.31-1"
},
{
"bug": 1061098,
"name": "libspreadsheet-parsexlsx-perl",
"type": "source",
"origin": null,
"release": "trixie",
"urgency": "not yet assigned",
"fixed_version": "0.31-1"
},
{
"bug": 1061098,
"name": "libspreadsheet-parsexlsx-perl",
"type": "source",
"origin": null,
"release": "bookworm",
"urgency": "not yet assigned",
"fixed_version": "0.27-3+deb12u2"
}
],
"distribution_packages": [
{
"name": "libspreadsheet-parsexlsx-perl",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.27-2+deb10u1build0.20.04.1"
}
]
}
],
"release": "20.04",
"versions": [
"0.27-2"
],
"ecosystem": "deb",
"fixed_version": "0.27-2+deb10u1build0.20.04.1",
"provider_record_id": "UBUNTU-CVE-2024-23525"
},
{
"name": "libspreadsheet-parsexlsx-perl",
"distro": "ubuntu",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.27-2.1+deb11u2build0.22.04.1"
}
]
}
],
"release": "22.04",
"versions": [
"0.27-2.1"
],
"ecosystem": "deb",
"fixed_version": "0.27-2.1+deb11u2build0.22.04.1",
"provider_record_id": "UBUNTU-CVE-2024-23525"
},
{
"name": "perl-Spreadsheet-ParseXLSX",
"distro": "opensuse",
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.310.0-1.1"
}
]
}
],
"release": "tumbleweed",
"versions": [],
"ecosystem": "rpm",
"fixed_version": "0.310.0-1.1",
"provider_record_id": "OPENSUSE-SU-2024:13760-1"
}
]
}OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
[Debian 12 (Bookworm)]
- [libspreadsheet-parsexlsx-perl]Unknown
Details (2)
0.27-3+deb12u2· all · bookwormFixed · Fixed:
0.27-3+deb12u2dsa · libspreadsheet-parsexlsx-perl · debian · bookworm; dsa · libspreadsheet-parsexlsx-perl · debian · 12
0.27-3+deb12u2· all · bookwormFixed · Fixed:
0.27-3+deb12u2dsa · libspreadsheet-parsexlsx-perl · debian · bookworm; dsa · libspreadsheet-parsexlsx-perl · debian · 12
[Debian 13 (Trixie)]
- [libspreadsheet-parsexlsx-perl]Unknown
Details (2)
0.36-1· all · trixieFixed · Fixed:
0.31-1dsa · libspreadsheet-parsexlsx-perl · debian · 13
0.36-1· all · trixieFixed · Fixed:
0.31-1dsa · libspreadsheet-parsexlsx-perl · debian · 13
[openSUSE Tumbleweed]
- [perl-Spreadsheet-ParseXLSX]Unknown
Source package: [perl-Spreadsheet-ParseXLSX]
Details (1)
0.370.0-1.3· noarch · tumbleweedFixed · Fixed:
0.310.0-1.1dsa · perl-Spreadsheet-ParseXLSX · opensuse · tumbleweed
Observed:
References
- [https://ftp.suse.com/pub/projects/security/csaf/opensuse-su-2024_13760-1.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2024-23525]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2024-23525]
- [https://osv.dev/vulnerability/openSUSE-SU-2024:13760-1]
- [https://security-tracker.debian.org/tracker/CVE-2024-23525]
[Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [SUSE security advisories and VEX]