
CVE catalog
CVE-2024-23638
squid: CVE-2024-23638
- Severity
- Medium · CVSS 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Published
- Source
- [NVD] · [CVE record]
- EPSS
- 60.05% · Oct 25, 2026
Squid is a caching proxy for the Web. Due to an expired pointer reference bug, Squid prior to version 6.6 is vulnerable to a Denial of Service attack against Cache Manager error responses. This problem allows a trusted client to perform Denial of Service when generating error pages for Client Manager reports. Squid older than 5.0.5 have not been tested and should be assumed to be vulnerable. All Squid-5.x up to and including 5.9 are vulnerable. All Squid-6.x up to and including 6.5 are vulnerable. This bug is fixed by Squid version 6.6. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. As a workaround, prevent access to Cache Manager using Squid's main access control: `http_access deny manager`.
Vulnerable and fixed packages
Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.
| Distribution | Package | Release | Version | Status |
|---|---|---|---|---|
| Debian | squid | sid | 7.7-1 | fixed |
| Debian | squid | forky | 7.7-1 | fixed |
| Debian | squid | trixie | 6.13-2+deb13u3 | fixed |
| Debian | squid | trixie-security | 6.13-2+deb13u2 | fixed |
| Debian | squid | bookworm | 5.7-2+deb12u5 | fixed |
| Debian | squid | bookworm-security | 5.7-2+deb12u6 | fixed |
| Ubuntu | squid3 | pro | 3.5.23-5ubuntu1 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.23-5ubuntu2 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.1 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.2 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.3 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.4 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.5 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.6 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.7 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.8 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.9 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.10 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.11 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.12 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.13 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm1 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm2 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm3 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm4 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm5 | vulnerable |
| Ubuntu | squid3 | pro | 3.5.27-1ubuntu1.14+esm6 | vulnerable |
| Ubuntu | squid | 20.04 | 4.8-1ubuntu2 | vulnerable |
| Ubuntu | squid | 20.04 | 4.8-1ubuntu3 | vulnerable |
| Ubuntu | squid | 20.04 | 4.9-2ubuntu1 | vulnerable |
| Ubuntu | squid | 20.04 | 4.9-2ubuntu2 | vulnerable |
| Ubuntu | squid | 20.04 | 4.9-2ubuntu3 | vulnerable |
| Ubuntu | squid | 20.04 | 4.9-2ubuntu4 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.1 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.2 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.3 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.4 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.5 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.6 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.7 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.8 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.9 | vulnerable |
| Ubuntu | squid | 20.04 | 4.10-1ubuntu1.10 | fixed |
| Ubuntu | squid | 22.04 | 4.13-10ubuntu5 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu1 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu3 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu4 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu4.1 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu4.2 | vulnerable |
| Ubuntu | squid | 22.04 | 5.2-1ubuntu4.3 | vulnerable |
| Ubuntu | squid | 22.04 | 5.7-0ubuntu0.22.04.1 | vulnerable |
| Ubuntu | squid | 22.04 | 5.7-0ubuntu0.22.04.2 | vulnerable |
| Ubuntu | squid | 22.04 | 5.7-0ubuntu0.22.04.3 | vulnerable |
| Ubuntu | squid | 22.04 | 5.7-0ubuntu0.22.04.4 | fixed |
Fixed-version evidence
| Distribution | Package | Type | Release | Fixed version | Urgency | Origin | Bugs |
|---|---|---|---|---|---|---|---|
| Debian | squid | source | sid | 6.6-1 | not yet assigned | Not reported | Not reported |
| Debian | squid | source | forky | 6.6-1 | not yet assigned | Not reported | Not reported |
| Debian | squid | source | trixie | 6.6-1 | not yet assigned | Not reported | Not reported |
| Debian | squid | source | bookworm | 5.7-2+deb12u1 | not yet assigned | Not reported | Not reported |
| Ubuntu | squid | deb | 20.04 | 4.10-1ubuntu1.10 | Not reported | UBUNTU-CVE-2024-23638 | Not reported |
| Ubuntu | squid | deb | 22.04 | 5.7-0ubuntu0.22.04.4 | Not reported | UBUNTU-CVE-2024-23638 | Not reported |
OpenFactory catalog packages
Matching against OpenFactory catalog package versions is in progress.
References
- [https://access.redhat.com/errata/RHSA-2024:4861]
- [https://ftp.suse.com/pub/projects/security/csaf/rhsa-2024_9644.json]
- [https://osv.dev/vulnerability/DEBIAN-CVE-2024-23638]
- [https://osv.dev/vulnerability/UBUNTU-CVE-2024-23638]
- [https://security-tracker.debian.org/tracker/CVE-2024-23638]
- [https://wid.cert-bund.de/.well-known/csaf/white/2024/wid-sec-w-2024-0180.json]
[CERT-Bund public advisories] · [Debian Security Tracker] · [FIRST EPSS] · [OSV Package Vulnerability Database] · [Red Hat security advisories and VEX] · [SUSE security advisories and VEX]