CVE catalog

CVE-2024-23807

UBUNTU-CVE-2024-23807

[CVE catalog]

Severity
Unknown
Published
Updated
Source
[NVD] · [CVE record]
EPSS
1.48% · Oct 25, 2026

The Apache Xerces C++ XML parser on versions 3.0.0 before 3.2.5 contains a use-after-free error triggered during the scanning of external DTDs. Users are recommended to upgrade to version 3.2.5 which fixes the issue, or mitigate the issue by disabling DTD processing. This can be accomplished via the DOM using a standard parser feature, or via SAX using the XERCES_DISABLE_DTD environment variable. This issue has been disclosed before as CVE-2018-1311, but unfortunately that advisory incorrectly stated the issue would be fixed in version 3.2.3 or 3.2.4.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Ubuntuxerces-cpro3.1.1-5.1vulnerable
Ubuntuxerces-cpro3.1.2+debian-1vulnerable
Ubuntuxerces-cpro3.1.3+debian-1vulnerable
Ubuntuxerces-cpro3.1.3+debian-1ubuntu0.1~esm1vulnerable
Ubuntuxerces-cpro3.1.3+debian-1ubuntu0.1~esm2fixed
Ubuntuxerces-cpro3.1.4+debian-2vulnerable
Ubuntuxerces-cpro3.1.4+debian-2build1vulnerable
Ubuntuxerces-cpro3.2.0+debian-2vulnerable
Ubuntuxerces-cpro3.2.0+debian-2ubuntu0.1~esm1vulnerable
Ubuntuxerces-cpro3.2.0+debian-2ubuntu0.1~esm2fixed
Ubuntuxerces-c22.043.2.3+debian-3vulnerable
Ubuntuxerces-c22.043.2.3+debian-3build1vulnerable
Ubuntuxerces-c22.043.2.3+debian-3ubuntu0.1fixed
Ubuntuxerces-cpro3.2.3+debian-3vulnerable
Ubuntuxerces-cpro3.2.3+debian-3build1vulnerable
Ubuntuxerces-cpro3.2.3+debian-3ubuntu0.1~esm1fixed

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Ubuntuxerces-cdebpro3.1.3+debian-1ubuntu0.1~esm2Not reportedUBUNTU-CVE-2024-23807Not reported
Ubuntuxerces-cdebpro3.2.0+debian-2ubuntu0.1~esm2Not reportedUBUNTU-CVE-2024-23807Not reported
Ubuntuxerces-cdeb22.043.2.3+debian-3ubuntu0.1Not reportedUBUNTU-CVE-2024-23807Not reported
Ubuntuxerces-cdebpro3.2.3+debian-3ubuntu0.1~esm1Not reportedUBUNTU-CVE-2024-23807Not reported

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

References