CVE catalog

CVE-2024-26308

libcommons-compress-java: CVE-2024-26308

[CVE catalog]

Severity
High · CVSS 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
Source
[NVD] · [CVE record]
EPSS
0.90% · Oct 25, 2026

Allocation of Resources Without Limits or Throttling vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.21 before 1.26. Users are recommended to upgrade to version 1.26, which fixes the issue.

Vulnerable and fixed packages

Distribution-reported package versions and fixes. These do not depend on matching against the OpenFactory package catalog.

DistributionPackageReleaseVersionStatus
Debianlibcommons-compress-javasid1.28.0-1fixed
Debianlibcommons-compress-javaforky1.28.0-1fixed
Debianlibcommons-compress-javatrixie1.27.1-2fixed
Debianlibcommons-compress-javabookworm1.22-1vulnerable

Fixed-version evidence

DistributionPackageTypeReleaseFixed versionUrgencyOriginBugs
Debianlibcommons-compress-javasourcesid1.27.1-1not yet assignedNot reported[1064414]
Debianlibcommons-compress-javasourceforky1.27.1-1not yet assignedNot reported[1064414]
Debianlibcommons-compress-javasourcetrixie1.27.1-1not yet assignedNot reported[1064414]
Debianlibcommons-compress-javasourcebookworm(unfixed)not yet assignedNot reported[1064414]

[Debian bug #1064414]

Notes

[bookworm] libcommons-compress-java: Minor issue

OpenFactory catalog packages

Matching against OpenFactory catalog package versions is in progress.

References